Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / configure.ac
CommitLineData
ac65e355
MD
1# -*- Autoconf -*-
2# Process this file with autoconf to produce a configure script.
3
43047f21 4AC_PREREQ([2.50])
90395824 5AC_INIT([babeltrace],[1.2.4],[mathieu dot desnoyers at efficios dot com])
3fbccce7
MD
6
7# Following the numbering scheme proposed by libtool for the library version
8# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
9AC_SUBST([BABELTRACE_LIBRARY_VERSION], [1:0:0])
10
ac65e355
MD
11AC_CONFIG_AUX_DIR([config])
12AC_CANONICAL_TARGET
13AC_CANONICAL_HOST
14AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
15m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
16
17AC_CONFIG_MACRO_DIR([m4])
18
abb7b782 19AC_PROG_MKDIR_P
ac65e355
MD
20
21AC_CONFIG_HEADERS([config.h])
22
217108a9
MD
23AC_SYS_LARGEFILE
24
ac65e355 25# Checks for programs.
267325e9 26AC_PROG_CC_STDC
ac65e355 27AC_PROG_MAKE_SET
aa225880 28LT_INIT
8b9d5b5e
MD
29AC_PROG_YACC
30AC_PROG_LEX
ac65e355 31
203d6b31
AM
32# Check linker option
33AX_APPEND_LINK_FLAGS([-Wl,--no-as-needed], [LD_NO_AS_NEEDED])
34AC_SUBST([LD_NO_AS_NEEDED])
35
331d78f5
YB
36if test ! -f "$srcdir/formats/ctf/metadata/ctf-parser.h"; then
37 if test x"$YACC" != "xbison -y"; then
38 AC_MSG_ERROR([[bison not found and is required when building from git.
39 Please install bison]])
40 fi
a66b40cc
JR
41 AC_PATH_PROG([BISON],[bison])
42 AX_PROG_BISON_VERSION([2.4], [],[
43 AC_MSG_ERROR([[Bison >= 2.4 is required when building from git]])
44 ])
331d78f5
YB
45fi
46
47if test ! -f "$srcdir/formats/ctf/metadata/ctf-lexer.c"; then
48 if test x"$LEX" != "xflex"; then
49 AC_MSG_ERROR([[flex not found and is required when building from git.
50 Please install flex]])
51 fi
fe709541
JR
52 AC_PATH_PROG([FLEX],[flex])
53 AX_PROG_FLEX_VERSION([2.5.35], [],[
54 AC_MSG_ERROR([[Flex >= 2.5.35 is required when building from git]])
55 ])
331d78f5
YB
56fi
57
e5f5317f 58
a6947cca 59AM_PATH_GLIB_2_0(2.22.0, ,AC_MSG_ERROR([glib is required in order to compile BabelTrace - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
ac65e355
MD
60
61# Checks for typedefs, structures, and compiler characteristics.
62AC_C_INLINE
63AC_TYPE_PID_T
64AC_TYPE_SIZE_T
65
66# Checks for library functions.
67AC_FUNC_MALLOC
68AC_FUNC_MMAP
ed959a6d 69AC_CHECK_FUNCS([gettimeofday munmap strtoul])
ac65e355 70
58819898
JI
71# Check for MinGW32.
72MINGW32=no
73case $host in
74 *-*-mingw*)
75 MINGW32=yes;;
76esac
77
78AM_CONDITIONAL([BABELTRACE_BUILD_WITH_MINGW], [test "x$MINGW32" = "xyes"])
79
9e8a1e08
MJ
80# Check what libraries are required on this platform to link sockets programs.
81AX_LIB_SOCKET_NSL
82
a4dfa07b
MD
83# Check for libuuid
84AC_CHECK_LIB([uuid], [uuid_generate],
85[
86 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_LIBUUID], 1, [Has libuuid support.])
87 have_libuuid=yes
88],
89[
90 # libuuid not found, check for uuid_create in libc.
91 AC_CHECK_LIB([c], [uuid_create],
92 [
93 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_LIBC_UUID], 1, [Has libc uuid support.])
94 have_libc_uuid=yes
95 ],
96 [
9d1e7de0
JI
97 # for MinGW32 we have our own internal implemenation of uuid using Windows functions.
98 if test "x$MINGW32" = xno; then
99 AC_MSG_ERROR([Cannot find libuuid uuid_generate nor libc uuid_create. Use [LDFLAGS]=-Ldir to specify their location.])
100 fi
a4dfa07b
MD
101 ])
102]
fd55fc57 103)
a4dfa07b
MD
104AM_CONDITIONAL([BABELTRACE_BUILD_WITH_LIBUUID], [test "x$have_libuuid" = "xyes"])
105AM_CONDITIONAL([BABELTRACE_BUILD_WITH_LIBC_UUID], [test "x$have_libc_uuid" = "xyes"])
fd55fc57 106
f8370579
MD
107# Check for fmemopen
108AC_CHECK_LIB([c], [fmemopen],
109[
110 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_FMEMOPEN], 1, [Has fmemopen support.])
111]
112)
113
114# Check for open_memstream
115AC_CHECK_LIB([c], [open_memstream],
116[
117 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_OPEN_MEMSTREAM], 1, [Has open_memstream support.])
118]
119)
120
0f536a74
TP
121AC_CHECK_LIB([popt], [poptGetContext], [],
122 [AC_MSG_ERROR([Cannot find popt.])]
123)
124
24a3136a
DS
125
126# For Python
127# SWIG version needed or newer:
128swig_version=2.0.0
129
94a6cea3
JG
130AC_ARG_ENABLE([python-bindings],
131 [AC_HELP_STRING([--enable-python-bindings],
132 [generate Python bindings])],
133 [enable_python=yes], [enable_python=no])
24a3136a
DS
134
135AM_CONDITIONAL([USE_PYTHON], [test "x${enable_python:-yes}" = xyes])
136
137if test "x${enable_python:-yes}" = xyes; then
24a3136a
DS
138 AX_PKG_SWIG($swig_version, [], [ AC_MSG_ERROR([SWIG $swig_version or newer is needed]) ])
139 AM_PATH_PYTHON
140
33287b16
JG
141 AM_PATH_PYTHON_MODULES([PYTHON])
142 # pythondir is the path where extra modules are to be installed
143 pythondir=$PYTHON_PREFIX/$PYTHON_MODULES_PATH
144 # pyexecdir is the path that contains shared objects used by the extra modules
145 pyexecdir=$PYTHON_EXEC_PREFIX/$PYTHON_MODULES_PATH
24a3136a
DS
146 AC_ARG_VAR([PYTHON_INCLUDE], [Include flags for python, bypassing python-config])
147 AC_ARG_VAR([PYTHON_CONFIG], [Path to python-config])
148 AS_IF([test -z "$PYTHON_INCLUDE"], [
149 AS_IF([test -z "$PYTHON_CONFIG"], [
150 AC_PATH_PROGS([PYTHON_CONFIG],
151 [python$PYTHON_VERSION-config python-config],
152 [no],
153 [`dirname $PYTHON`])
94a6cea3 154 AS_IF([test "$PYTHON_CONFIG" = no], [AC_MSG_ERROR([cannot find python-config for $PYTHON. Do you have python-dev installed?])])
24a3136a
DS
155 ])
156 AC_MSG_CHECKING([python include flags])
157 PYTHON_INCLUDE=`$PYTHON_CONFIG --includes`
158 AC_MSG_RESULT([$PYTHON_INCLUDE])
159 ])
94a6cea3
JG
160
161else
162 AC_MSG_NOTICE([You may configure with --enable-python-bindings ]dnl
163[if you want Python bindings.])
164
24a3136a
DS
165fi
166
ac65e355
MD
167pkg_modules="gmodule-2.0 >= 2.0.0"
168PKG_CHECK_MODULES(GMODULE, [$pkg_modules])
169AC_SUBST(PACKAGE_LIBS)
170
34d3acc4 171LIBS="$LIBS $GMODULE_LIBS"
217108a9 172PACKAGE_CFLAGS="$GMODULE_CFLAGS -Wall -Wformat -include config.h"
ac65e355
MD
173AC_SUBST(PACKAGE_CFLAGS)
174
e4d70dc3 175babeltraceincludedir="${includedir}/babeltrace"
70bd0a12
JD
176AC_SUBST(babeltraceincludedir)
177
64a35d1b
JD
178babeltracectfincludedir="${includedir}/babeltrace/ctf"
179AC_SUBST(babeltracectfincludedir)
180
273b65be
JG
181babeltracectfwriterincludedir="${includedir}/babeltrace/ctf-writer"
182AC_SUBST(babeltracectfwriterincludedir)
183
ac65e355
MD
184AC_CONFIG_FILES([
185 Makefile
186 types/Makefile
9d1e7de0 187 compat/Makefile
ac65e355
MD
188 formats/Makefile
189 formats/ctf/Makefile
190 formats/ctf/types/Makefile
1ae19169
MD
191 formats/ctf-text/Makefile
192 formats/ctf-text/types/Makefile
5d93a76e 193 formats/ctf-metadata/Makefile
22133895 194 formats/bt-dummy/Makefile
4a744367 195 formats/lttng-live/Makefile
8b9d5b5e 196 formats/ctf/metadata/Makefile
273b65be 197 formats/ctf/writer/Makefile
4c8bfb7e 198 converter/Makefile
d2c0553c 199 doc/Makefile
1eb0c69c 200 lib/Makefile
74f21e2d 201 lib/prio_heap/Makefile
e92927d1 202 include/Makefile
24a3136a
DS
203 bindings/Makefile
204 bindings/python/Makefile
ac65e355 205 tests/Makefile
19badea8 206 tests/bin/Makefile
aa968dde 207 tests/lib/Makefile
1833a3d1
CB
208 tests/utils/Makefile
209 tests/utils/tap/Makefile
6aa249b5
MD
210 extras/Makefile
211 extras/valgrind/Makefile
d0acc96d 212 babeltrace.pc
e7a7efdb 213 babeltrace-ctf.pc
ac65e355
MD
214])
215AC_OUTPUT
This page took 0.056134 seconds and 4 git commands to generate.