Port: implement posix_fallocate wrapper
[babeltrace.git] / configure.ac
CommitLineData
43047f21 1AC_PREREQ([2.50])
90395824 2AC_INIT([babeltrace],[1.2.4],[mathieu dot desnoyers at efficios dot com])
3fbccce7
MD
3
4# Following the numbering scheme proposed by libtool for the library version
5# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
6AC_SUBST([BABELTRACE_LIBRARY_VERSION], [1:0:0])
7
9d5a2885 8AC_CONFIG_HEADERS([config.h])
ac65e355 9AC_CONFIG_AUX_DIR([config])
9d5a2885
MJ
10AC_CONFIG_MACRO_DIR([m4])
11
ac65e355
MD
12AC_CANONICAL_TARGET
13AC_CANONICAL_HOST
ac65e355 14
9d5a2885
MJ
15AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
16AM_MAINTAINER_MODE([enable])
ac65e355 17
9d5a2885
MJ
18# Enable silent rules if available (Introduced in AM 1.11)
19m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
ac65e355 20
9d5a2885
MJ
21# Checks for C compiler
22AC_USE_SYSTEM_EXTENSIONS
217108a9 23AC_SYS_LARGEFILE
9d5a2885
MJ
24AC_PROG_CC
25AC_PROG_CC_STDC
217108a9 26
ac65e355 27# Checks for programs.
ac65e355 28AC_PROG_MAKE_SET
aa225880 29LT_INIT
8b9d5b5e
MD
30AC_PROG_YACC
31AC_PROG_LEX
9d5a2885
MJ
32AC_PROG_MKDIR_P
33AC_PROG_LN_S
ac65e355 34
58cb7c63
MJ
35AX_C___ATTRIBUTE__
36AS_IF([test "x$ax_cv___attribute__" = "xyes"],
37 [:],
38 [AC_MSG_ERROR([The compiler does not support __attribute__ extensions])])
39
909d3caa
MJ
40AX_PTHREAD(,[AC_MSG_ERROR([Could not configure pthreads support])])
41LIBS="$PTHREAD_LIBS $LIBS"
42CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
43CC="$PTHREAD_CC"
44
203d6b31
AM
45# Check linker option
46AX_APPEND_LINK_FLAGS([-Wl,--no-as-needed], [LD_NO_AS_NEEDED])
47AC_SUBST([LD_NO_AS_NEEDED])
48
9d5a2885
MJ
49AC_CHECK_HEADERS([fcntl.h limits.h netdb.h netinet/in.h stddef.h sys/socket.h])
50
331d78f5
YB
51if test ! -f "$srcdir/formats/ctf/metadata/ctf-parser.h"; then
52 if test x"$YACC" != "xbison -y"; then
53 AC_MSG_ERROR([[bison not found and is required when building from git.
54 Please install bison]])
55 fi
a66b40cc
JR
56 AC_PATH_PROG([BISON],[bison])
57 AX_PROG_BISON_VERSION([2.4], [],[
58 AC_MSG_ERROR([[Bison >= 2.4 is required when building from git]])
59 ])
331d78f5
YB
60fi
61
62if test ! -f "$srcdir/formats/ctf/metadata/ctf-lexer.c"; then
63 if test x"$LEX" != "xflex"; then
64 AC_MSG_ERROR([[flex not found and is required when building from git.
65 Please install flex]])
66 fi
fe709541
JR
67 AC_PATH_PROG([FLEX],[flex])
68 AX_PROG_FLEX_VERSION([2.5.35], [],[
69 AC_MSG_ERROR([[Flex >= 2.5.35 is required when building from git]])
70 ])
331d78f5
YB
71fi
72
e5f5317f 73
a6947cca 74AM_PATH_GLIB_2_0(2.22.0, ,AC_MSG_ERROR([glib is required in order to compile BabelTrace - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
ac65e355
MD
75
76# Checks for typedefs, structures, and compiler characteristics.
77AC_C_INLINE
78AC_TYPE_PID_T
79AC_TYPE_SIZE_T
80
81# Checks for library functions.
82AC_FUNC_MALLOC
83AC_FUNC_MMAP
ed959a6d 84AC_CHECK_FUNCS([gettimeofday munmap strtoul])
ac65e355 85
58819898
JI
86# Check for MinGW32.
87MINGW32=no
88case $host in
89 *-*-mingw*)
90 MINGW32=yes;;
91esac
92
93AM_CONDITIONAL([BABELTRACE_BUILD_WITH_MINGW], [test "x$MINGW32" = "xyes"])
94
9e8a1e08
MJ
95# Check what libraries are required on this platform to link sockets programs.
96AX_LIB_SOCKET_NSL
97
a4dfa07b
MD
98# Check for libuuid
99AC_CHECK_LIB([uuid], [uuid_generate],
100[
101 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_LIBUUID], 1, [Has libuuid support.])
102 have_libuuid=yes
103],
104[
105 # libuuid not found, check for uuid_create in libc.
106 AC_CHECK_LIB([c], [uuid_create],
107 [
108 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_LIBC_UUID], 1, [Has libc uuid support.])
109 have_libc_uuid=yes
110 ],
111 [
9d1e7de0
JI
112 # for MinGW32 we have our own internal implemenation of uuid using Windows functions.
113 if test "x$MINGW32" = xno; then
114 AC_MSG_ERROR([Cannot find libuuid uuid_generate nor libc uuid_create. Use [LDFLAGS]=-Ldir to specify their location.])
115 fi
a4dfa07b
MD
116 ])
117]
fd55fc57 118)
a4dfa07b
MD
119AM_CONDITIONAL([BABELTRACE_BUILD_WITH_LIBUUID], [test "x$have_libuuid" = "xyes"])
120AM_CONDITIONAL([BABELTRACE_BUILD_WITH_LIBC_UUID], [test "x$have_libc_uuid" = "xyes"])
fd55fc57 121
f8370579
MD
122# Check for fmemopen
123AC_CHECK_LIB([c], [fmemopen],
124[
125 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_FMEMOPEN], 1, [Has fmemopen support.])
126]
127)
128
129# Check for open_memstream
130AC_CHECK_LIB([c], [open_memstream],
131[
132 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_OPEN_MEMSTREAM], 1, [Has open_memstream support.])
133]
134)
135
edcad9c1
JG
136# Check for posix_fallocate
137AC_CHECK_LIB([c], [posix_fallocate],
138[
139 AC_DEFINE_UNQUOTED([BABELTRACE_HAVE_POSIX_FALLOCATE], 1, [Has posix_fallocate support.])
140]
141)
142
0f536a74
TP
143AC_CHECK_LIB([popt], [poptGetContext], [],
144 [AC_MSG_ERROR([Cannot find popt.])]
145)
146
24a3136a
DS
147
148# For Python
149# SWIG version needed or newer:
150swig_version=2.0.0
151
94a6cea3
JG
152AC_ARG_ENABLE([python-bindings],
153 [AC_HELP_STRING([--enable-python-bindings],
154 [generate Python bindings])],
155 [enable_python=yes], [enable_python=no])
24a3136a
DS
156
157AM_CONDITIONAL([USE_PYTHON], [test "x${enable_python:-yes}" = xyes])
158
159if test "x${enable_python:-yes}" = xyes; then
24a3136a
DS
160 AX_PKG_SWIG($swig_version, [], [ AC_MSG_ERROR([SWIG $swig_version or newer is needed]) ])
161 AM_PATH_PYTHON
162
33287b16
JG
163 AM_PATH_PYTHON_MODULES([PYTHON])
164 # pythondir is the path where extra modules are to be installed
165 pythondir=$PYTHON_PREFIX/$PYTHON_MODULES_PATH
166 # pyexecdir is the path that contains shared objects used by the extra modules
167 pyexecdir=$PYTHON_EXEC_PREFIX/$PYTHON_MODULES_PATH
24a3136a
DS
168 AC_ARG_VAR([PYTHON_INCLUDE], [Include flags for python, bypassing python-config])
169 AC_ARG_VAR([PYTHON_CONFIG], [Path to python-config])
170 AS_IF([test -z "$PYTHON_INCLUDE"], [
171 AS_IF([test -z "$PYTHON_CONFIG"], [
172 AC_PATH_PROGS([PYTHON_CONFIG],
173 [python$PYTHON_VERSION-config python-config],
174 [no],
175 [`dirname $PYTHON`])
94a6cea3 176 AS_IF([test "$PYTHON_CONFIG" = no], [AC_MSG_ERROR([cannot find python-config for $PYTHON. Do you have python-dev installed?])])
24a3136a
DS
177 ])
178 AC_MSG_CHECKING([python include flags])
179 PYTHON_INCLUDE=`$PYTHON_CONFIG --includes`
180 AC_MSG_RESULT([$PYTHON_INCLUDE])
181 ])
94a6cea3
JG
182
183else
184 AC_MSG_NOTICE([You may configure with --enable-python-bindings ]dnl
185[if you want Python bindings.])
186
24a3136a
DS
187fi
188
ac65e355
MD
189pkg_modules="gmodule-2.0 >= 2.0.0"
190PKG_CHECK_MODULES(GMODULE, [$pkg_modules])
191AC_SUBST(PACKAGE_LIBS)
192
34d3acc4 193LIBS="$LIBS $GMODULE_LIBS"
217108a9 194PACKAGE_CFLAGS="$GMODULE_CFLAGS -Wall -Wformat -include config.h"
ac65e355
MD
195AC_SUBST(PACKAGE_CFLAGS)
196
e4d70dc3 197babeltraceincludedir="${includedir}/babeltrace"
70bd0a12
JD
198AC_SUBST(babeltraceincludedir)
199
64a35d1b
JD
200babeltracectfincludedir="${includedir}/babeltrace/ctf"
201AC_SUBST(babeltracectfincludedir)
202
273b65be
JG
203babeltracectfwriterincludedir="${includedir}/babeltrace/ctf-writer"
204AC_SUBST(babeltracectfwriterincludedir)
205
ac65e355
MD
206AC_CONFIG_FILES([
207 Makefile
208 types/Makefile
9d1e7de0 209 compat/Makefile
ac65e355
MD
210 formats/Makefile
211 formats/ctf/Makefile
212 formats/ctf/types/Makefile
1ae19169
MD
213 formats/ctf-text/Makefile
214 formats/ctf-text/types/Makefile
5d93a76e 215 formats/ctf-metadata/Makefile
22133895 216 formats/bt-dummy/Makefile
4a744367 217 formats/lttng-live/Makefile
8b9d5b5e 218 formats/ctf/metadata/Makefile
273b65be 219 formats/ctf/writer/Makefile
4c8bfb7e 220 converter/Makefile
d2c0553c 221 doc/Makefile
1eb0c69c 222 lib/Makefile
74f21e2d 223 lib/prio_heap/Makefile
e92927d1 224 include/Makefile
24a3136a
DS
225 bindings/Makefile
226 bindings/python/Makefile
ac65e355 227 tests/Makefile
19badea8 228 tests/bin/Makefile
aa968dde 229 tests/lib/Makefile
1833a3d1
CB
230 tests/utils/Makefile
231 tests/utils/tap/Makefile
6aa249b5
MD
232 extras/Makefile
233 extras/valgrind/Makefile
d0acc96d 234 babeltrace.pc
e7a7efdb 235 babeltrace-ctf.pc
ac65e355
MD
236])
237AC_OUTPUT
This page took 0.058034 seconds and 4 git commands to generate.