Remove everything related to the `bt2.ctf_writer` Python module
[babeltrace.git] / bindings / python / bt2 / Makefile.am
index a1d3b1ae0c461de85cf8659c0e7b9fc1281c63f6..31d9e1773c4ab0d24c969dd13607ef72b8151e22 100644 (file)
@@ -1,5 +1,5 @@
 # Since the shared object used by the python bindings is not built with
-# libtool, we need to add the directory containing libbabeltrace to the
+# libtool, we need to add the directory containing libbabeltrace2 to the
 # linker path.
 AM_LDFLAGS=-L$(top_builddir)/lib/.libs
 
@@ -33,16 +33,15 @@ STATIC_BINDINGS_DEPS =                                      \
        bt2/native_bt_trace.i                           \
        bt2/native_bt_value.i                           \
        bt2/native_bt_version.i                         \
-       bt2/clock_class_priority_map.py                 \
        bt2/clock_class.py                              \
        bt2/clock_snapshot.py                           \
        bt2/component.py                                \
        bt2/connection.py                               \
-       bt2/ctf_writer.py                               \
        bt2/event_class.py                              \
        bt2/event.py                                    \
        bt2/field.py                                    \
        bt2/field_class.py                              \
+       bt2/field_path.py                               \
        bt2/graph.py                                    \
        bt2/logging.py                                  \
        bt2/message_iterator.py                         \
@@ -56,6 +55,7 @@ STATIC_BINDINGS_DEPS =                                        \
        bt2/stream_class.py                             \
        bt2/stream.py                                   \
        bt2/trace.py                                    \
+       bt2/trace_class.py                              \
        bt2/trace_collection_message_iterator.py        \
        bt2/utils.py                                    \
        bt2/value.py
@@ -71,7 +71,7 @@ BUILD_FLAGS=CC="$(CC)" \
 
 all-local: build-python-bindings.stamp
 
-copy-static-deps.stamp: $(STATIC_BINDINGS_DEPS)
+copy-static-deps.stamp: $(addprefix $(srcdir)/, $(STATIC_BINDINGS_DEPS))
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for file in $(STATIC_BINDINGS_DEPS); do \
                        cp -f $(srcdir)/$$file $(builddir)/$$file; \
This page took 0.023645 seconds and 4 git commands to generate.