Link statically to internal libraries
[babeltrace.git] / converter / Makefile.am
index 2b16f1e4baa93e3958ff6a9dd96a050dc5d7a306..389a9d98a84c8fe4e851334533266b443693f448 100644 (file)
@@ -7,20 +7,16 @@ babeltrace_SOURCES = \
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
-# side-effects as dead code. Note: we put plugin dependencies on the
-# executable rather than the library because libtool does not seem to
-# issue the LDFLAGS before the rpaths, which makes it useless.
+# side-effects as dead code.
 babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       $(top_builddir)/formats/ctf/metadata/libctf-ast.la \
-       $(top_builddir)/formats/ctf-text/libctf-text.la \
-       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
+       $(top_builddir)/formats/ctf-text/libbabeltrace-ctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbabeltrace-dummy.la
 
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
This page took 0.023531 seconds and 4 git commands to generate.