API : iterator namespace cleanup
[babeltrace.git] / converter / Makefile.am
index 3ecca8c2c24d61f3637f78d090479eabc0832d9b..578280a681e4427f8d0fd9e47b348aa0e69bef2e 100644 (file)
@@ -1,12 +1,25 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
 
-bin_PROGRAMS = babeltrace
+bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
        babeltrace.c
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code. Note: we put plugin dependencies on the
+# executable rather than the library because libtool does not seem to
+# issue the LDFLAGS before the rpaths, which makes it useless.
+babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
-       $(top_srcdir)/types/libtypes.a \
-       $(top_srcdir)/formats/libregistry.a
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la \
+       $(top_builddir)/formats/ctf-text/libctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
 
+babeltrace_log_SOURCES = babeltrace-log.c
 
+babeltrace_log_LDADD = \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la
This page took 0.024198 seconds and 4 git commands to generate.