API : iterator namespace cleanup
[babeltrace.git] / converter / Makefile.am
index 4d573616a278bb9d37af831eee041403f4825ef5..578280a681e4427f8d0fd9e47b348aa0e69bef2e 100644 (file)
@@ -1,20 +1,25 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
 
-bin_PROGRAMS = babeltrace
-
-lib_LTLIBRARIES = libbabeltrace.la
-
-libbabeltrace_la_SOURCES = \
-       babeltrace-lib.c
-
-libbabeltrace_la_LIBADD = \
-       $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       $(top_builddir)/formats/ctf-text/libctf-text.la
+bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
        babeltrace.c
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code. Note: we put plugin dependencies on the
+# executable rather than the library because libtool does not seem to
+# issue the LDFLAGS before the rpaths, which makes it useless.
+babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
-       libbabeltrace.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la \
+       $(top_builddir)/formats/ctf-text/libctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
+
+babeltrace_log_SOURCES = babeltrace-log.c
+
+babeltrace_log_LDADD = \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la
This page took 0.023576 seconds and 4 git commands to generate.