Add Windows exe files to .gitignore
[babeltrace.git] / converter / Makefile.am
index 2622e9ca67a00a90738f247747539fd14411bb52..8ef71a23ec91d7b1b22e9eb3299e4ed139b059d0 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_LDFLAGS = -lpopt
 
 bin_PROGRAMS = babeltrace babeltrace-log
 
@@ -13,6 +14,7 @@ babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
        $(top_builddir)/formats/ctf-text/libbabeltrace-ctf-text.la \
+       $(top_builddir)/formats/ctf-metadata/libbabeltrace-ctf-metadata.la \
        $(top_builddir)/formats/bt-dummy/libbabeltrace-dummy.la
 
 babeltrace_log_SOURCES = babeltrace-log.c
@@ -27,3 +29,8 @@ endif
 if BABELTRACE_BUILD_WITH_LIBC_UUID
 babeltrace_log_LDADD += -lc
 endif
+
+if BABELTRACE_BUILD_WITH_MINGW
+babeltrace_log_LDADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt -lpthread
+babeltrace_LDADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt -lpthread
+endif
This page took 0.023544 seconds and 4 git commands to generate.