Combine duplicated API/pretty-print timestamp code
[babeltrace.git] / converter / Makefile.am
index e7bcc690a6ef767e0e7be167d456fd75283219f2..9443c2148848d681d1817ba462f11ac1c9b2f44a 100644 (file)
@@ -2,25 +2,24 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
 
 bin_PROGRAMS = babeltrace babeltrace-log
 
-lib_LTLIBRARIES = libbabeltrace.la
-
-libbabeltrace_la_SOURCES = \
-       babeltrace-lib.c
-
-libbabeltrace_la_LIBADD = \
-       $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       $(top_builddir)/formats/ctf-text/libctf-text.la
-
 babeltrace_SOURCES = \
        babeltrace.c
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code. Note: we put plugin dependencies on the
+# executable rather than the library because libtool does not seem to
+# issue the LDFLAGS before the rpaths, which makes it useless.
+babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
-       libbabeltrace.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libctf.la \
+       $(top_builddir)/formats/ctf/metadata/libctf-ast.la \
+       $(top_builddir)/formats/ctf-text/libctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
 
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libctf.la
This page took 0.024181 seconds and 4 git commands to generate.