Python bindings: add has_intersection property to TraceCollection
[babeltrace.git] / converter / Makefile.am
index 374d1d47f11a5e3cfc8aa852dbd2baf98907b986..aba3333dc29ba06ed3f622b1a5f8ec288cf6e703 100644 (file)
@@ -9,7 +9,7 @@ babeltrace_SOURCES = \
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-babeltrace_LDFLAGS = -Wl,--no-as-needed
+babeltrace_LDFLAGS = $(LD_NO_AS_NEEDED)
 babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
@@ -19,6 +19,10 @@ babeltrace_LDADD = \
        $(top_builddir)/formats/bt-dummy/libbabeltrace-dummy.la \
        $(top_builddir)/formats/lttng-live/libbabeltrace-lttng-live.la
 
+if ENABLE_DEBUGINFO
+babeltrace_LDADD += $(top_builddir)/lib/libdebuginfo.la
+endif
+
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
This page took 0.023255 seconds and 4 git commands to generate.