Python bindings: add has_intersection property to TraceCollection
[babeltrace.git] / converter / Makefile.am
index 578280a681e4427f8d0fd9e47b348aa0e69bef2e..aba3333dc29ba06ed3f622b1a5f8ec288cf6e703 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_LDFLAGS = -lpopt
 
 bin_PROGRAMS = babeltrace babeltrace-log
 
@@ -7,19 +8,36 @@ babeltrace_SOURCES = \
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
-# side-effects as dead code. Note: we put plugin dependencies on the
-# executable rather than the library because libtool does not seem to
-# issue the LDFLAGS before the rpaths, which makes it useless.
-babeltrace_LDFLAGS = -Wl,--no-as-needed
+# side-effects as dead code.
+babeltrace_LDFLAGS = $(LD_NO_AS_NEEDED)
 babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       $(top_builddir)/formats/ctf-text/libctf-text.la \
-       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
+       $(top_builddir)/compat/libcompat.la \
+       $(top_builddir)/formats/ctf-text/libbabeltrace-ctf-text.la \
+       $(top_builddir)/formats/ctf-metadata/libbabeltrace-ctf-metadata.la \
+       $(top_builddir)/formats/bt-dummy/libbabeltrace-dummy.la \
+       $(top_builddir)/formats/lttng-live/libbabeltrace-lttng-live.la
+
+if ENABLE_DEBUGINFO
+babeltrace_LDADD += $(top_builddir)/lib/libdebuginfo.la
+endif
 
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
+       $(top_builddir)/compat/libcompat.la
+
+if BABELTRACE_BUILD_WITH_LIBUUID
+babeltrace_log_LDADD += -luuid
+endif
+if BABELTRACE_BUILD_WITH_LIBC_UUID
+babeltrace_log_LDADD += -lc
+endif
+
+if BABELTRACE_BUILD_WITH_MINGW
+babeltrace_log_LDADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt -lpthread
+babeltrace_LDADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt -lpthread
+endif
This page took 0.023146 seconds and 4 git commands to generate.