Show field names by default, enhance --names option
[babeltrace.git] / converter / Makefile.am
index 3ecca8c2c24d61f3637f78d090479eabc0832d9b..b836d248ada5b5fd4d8d278c279765244f3319ba 100644 (file)
@@ -1,12 +1,34 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -lpopt
 
-bin_PROGRAMS = babeltrace
+bin_PROGRAMS = babeltrace babeltrace-log
+
+lib_LTLIBRARIES = libbabeltrace.la
+
+libbabeltrace_la_SOURCES = \
+       babeltrace-lib.c
+
+libbabeltrace_la_LIBADD = \
+       $(top_builddir)/types/libbabeltrace_types.la \
+       $(top_builddir)/lib/libprio_heap.la
 
 babeltrace_SOURCES = \
        babeltrace.c
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code. Note: we put plugin dependencies on the
+# executable rather than the library because libtool does not seem to
+# issue the LDFLAGS before the rpaths, which makes it useless.
+babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
-       $(top_srcdir)/types/libtypes.a \
-       $(top_srcdir)/formats/libregistry.a
+       libbabeltrace.la \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la \
+       $(top_builddir)/formats/ctf-text/libctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
 
+babeltrace_log_SOURCES = babeltrace-log.c
 
+babeltrace_log_LDADD = \
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la
This page took 0.024032 seconds and 4 git commands to generate.