Fix support for gold linker: inappropriate dep removal of plugins
[babeltrace.git] / converter / Makefile.am
index a47a18dcd23430bc2c37d0f7ca8b4d9d2ce921fd..b836d248ada5b5fd4d8d278c279765244f3319ba 100644 (file)
@@ -9,17 +9,23 @@ libbabeltrace_la_SOURCES = \
 
 libbabeltrace_la_LIBADD = \
        $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       $(top_builddir)/formats/ctf-text/libctf-text.la \
-       $(top_builddir)/formats/bt-dummy/libbt-dummy.la \
        $(top_builddir)/lib/libprio_heap.la
 
 babeltrace_SOURCES = \
        babeltrace.c
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code. Note: we put plugin dependencies on the
+# executable rather than the library because libtool does not seem to
+# issue the LDFLAGS before the rpaths, which makes it useless.
+babeltrace_LDFLAGS = -Wl,--no-as-needed
 babeltrace_LDADD = \
        libbabeltrace.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la
+       $(top_builddir)/formats/libbabeltrace_registry.la \
+       $(top_builddir)/formats/ctf/libctf.la \
+       $(top_builddir)/formats/ctf-text/libctf-text.la \
+       $(top_builddir)/formats/bt-dummy/libbt-dummy.la
 
 babeltrace_log_SOURCES = babeltrace-log.c
 
This page took 0.022553 seconds and 4 git commands to generate.