Combine duplicated API/pretty-print timestamp code
[babeltrace.git] / formats / ctf / Makefile.am
index ba0a4f79404b06fb22f72145bfdf78f0a23cbe78..a85e7d3eed0871f0d6679183e497e26541e99983 100644 (file)
@@ -1,11 +1,17 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 
-SUBDIRS = . types
-#metadata
+SUBDIRS = types metadata .
 
 lib_LTLIBRARIES = libctf.la
 
 libctf_la_SOURCES = \
        ctf.c \
-       types/ctf_types.o
-#      metadata/ctf_parse.o
+       events.c \
+       callbacks.c \
+       events-private.h
+
+libctf_la_LIBADD = \
+       types/libctf-types.la \
+       metadata/libctf-parser.la \
+       metadata/libctf-ast.la \
+       $(top_builddir)/lib/libbabeltrace.la
This page took 0.022989 seconds and 4 git commands to generate.