Fix: missing includes break the out-of-tree build
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index 85db70647c3a1595daddbacffe882667376c10eb..1f8e76e3a0e80b9947e79289837a00f76294d2d3 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
+               -I$(top_srcdir)/formats/ctf/metadata
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
@@ -11,13 +12,13 @@ noinst_HEADERS = \
        objstack.h
 
 libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -include ctf-scanner-symbols.h
+libctf_parser_la_CFLAGS = $(AM_CFLAGS)
 
+libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
                ctf-visitor-semantic-validator.c \
                ctf-visitor-generate-io-struct.c
-
 libctf_ast_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
 
@@ -33,7 +34,7 @@ endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
-
+ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
This page took 0.025511 seconds and 4 git commands to generate.