Fix: missing includes break the out-of-tree build
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index a7f633d9b0f013476068674eeb050dbf6f8de8fc..1f8e76e3a0e80b9947e79289837a00f76294d2d3 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
+               -I$(top_srcdir)/formats/ctf/metadata
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
@@ -6,15 +7,18 @@ noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
 noinst_HEADERS = \
        ctf-scanner.h \
-       ctf-ast.h
+       ctf-ast.h \
+       ctf-scanner-symbols.h \
+       objstack.h
 
-libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y
+libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
+libctf_parser_la_CFLAGS = $(AM_CFLAGS)
 
+libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
                ctf-visitor-semantic-validator.c \
                ctf-visitor-generate-io-struct.c
-
 libctf_ast_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
 
@@ -24,10 +28,15 @@ endif
 if BABELTRACE_BUILD_WITH_LIBC_UUID
 libctf_ast_la_LIBADD += -lc
 endif
+if BABELTRACE_BUILD_WITH_MINGW
+libctf_ast_la_LIBADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt
+endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
-
+ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
+
+CLEANFILES = ctf-lexer.c ctf-parser.c ctf-parser.h ctf-parser.output
This page took 0.02435 seconds and 4 git commands to generate.