Add missing lex/bison generated files to make clean
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index a7f633d9b0f013476068674eeb050dbf6f8de8fc..3d9a2500d82a6aa6b85c2d32f62cba148e10d6b3 100644 (file)
@@ -6,9 +6,12 @@ noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
 noinst_HEADERS = \
        ctf-scanner.h \
-       ctf-ast.h
+       ctf-ast.h \
+       ctf-scanner-symbols.h \
+       objstack.h
 
-libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y
+libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) -include ctf-scanner-symbols.h
 
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
@@ -31,3 +34,5 @@ ctf_parser_test_SOURCES = ctf-parser-test.c
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
+
+CLEANFILES = ctf-lexer.c ctf-parser.c ctf-parser.h ctf-parser.output
This page took 0.024599 seconds and 4 git commands to generate.