CTF metadata structure generation code finished
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index fac978cce68bef88377d9246ff27708b525bd3a0..50b50430ff6b4dba58cc9df5586677059e74643e 100644 (file)
@@ -2,6 +2,17 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d
 
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d
 
-noinst_LIBRARIES = libctf-parser.a
+noinst_LIBRARIES = libctf-parser.a libctf-ast.a
 
 libctf_parser_a_SOURCES = ctf-lexer.l ctf-parser.y
 
 libctf_parser_a_SOURCES = ctf-lexer.l ctf-parser.y
+
+libctf_ast_a_SOURCES = ctf-visitor-xml.c \
+               ctf-visitor-parent-links.c \
+               ctf-visitor-semantic-validator.c \
+               ctf-visitor-generate-io-struct.c
+
+bin_PROGRAMS = ctf-parser-test
+ctf_parser_test_SOURCES = ctf-parser-test.c
+ctf_parser_test_LDADD = libctf-parser.a \
+               libctf-ast.a \
+               $(top_builddir)/types/libtypes.a
This page took 0.02349 seconds and 4 git commands to generate.