Fix: Missing postfix_expression DOT keywords in CTF grammar
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index 0725dce3d826bfba62a1249d790570b059907391..85db70647c3a1595daddbacffe882667376c10eb 100644 (file)
@@ -6,9 +6,12 @@ noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
 noinst_HEADERS = \
        ctf-scanner.h \
-       ctf-ast.h
+       ctf-ast.h \
+       ctf-scanner-symbols.h \
+       objstack.h
 
-libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y
+libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) -include ctf-scanner-symbols.h
 
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
@@ -16,7 +19,17 @@ libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-generate-io-struct.c
 
 libctf_ast_la_LIBADD = \
-                $(top_builddir)/types/libbabeltrace_types.la
+       $(top_builddir)/lib/libbabeltrace.la
+
+if BABELTRACE_BUILD_WITH_LIBUUID
+libctf_ast_la_LIBADD += -luuid
+endif
+if BABELTRACE_BUILD_WITH_LIBC_UUID
+libctf_ast_la_LIBADD += -lc
+endif
+if BABELTRACE_BUILD_WITH_MINGW
+libctf_ast_la_LIBADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt
+endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
@@ -24,3 +37,5 @@ ctf_parser_test_SOURCES = ctf-parser-test.c
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
+
+CLEANFILES = ctf-lexer.c ctf-parser.c ctf-parser.h ctf-parser.output
This page took 0.023516 seconds and 4 git commands to generate.