Create BSD wrapper for uuid
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index 09f105f1f42689c7d6010fe2ce57819e5d60e0e9..a7f633d9b0f013476068674eeb050dbf6f8de8fc 100644 (file)
@@ -2,7 +2,7 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
-lib_LTLIBRARIES = libctf-parser.la libctf-ast.la
+noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
 noinst_HEADERS = \
        ctf-scanner.h \
@@ -16,9 +16,16 @@ libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-generate-io-struct.c
 
 libctf_ast_la_LIBADD = \
-                $(top_builddir)/types/libbabeltrace_types.la
+       $(top_builddir)/lib/libbabeltrace.la
 
-bin_PROGRAMS = ctf-parser-test
+if BABELTRACE_BUILD_WITH_LIBUUID
+libctf_ast_la_LIBADD += -luuid
+endif
+if BABELTRACE_BUILD_WITH_LIBC_UUID
+libctf_ast_la_LIBADD += -lc
+endif
+
+noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
 
 ctf_parser_test_LDADD = \
This page took 0.023341 seconds and 4 git commands to generate.