Create BSD wrapper for uuid
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index 499141ebde064d4f055a2dd8a269c6af2c9d9954..a7f633d9b0f013476068674eeb050dbf6f8de8fc 100644 (file)
@@ -1,15 +1,33 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 BUILT_SOURCES = ctf-parser.h
-AM_YFLAGS = -t -d
+AM_YFLAGS = -t -d -v
 
-noinst_LIBRARIES = libctf-parser.a
+noinst_LTLIBRARIES = libctf-parser.la libctf-ast.la
 
-libctf_parser_a_SOURCES = ctf-lexer.l ctf-parser.y
+noinst_HEADERS = \
+       ctf-scanner.h \
+       ctf-ast.h
 
-bin_PROGRAMS = ctf-parser-test
-ctf_parser_test_SOURCES = \
-                       ctf-parser-test.c ctf-visitor-xml.c \
-                       ctf-visitor-parent-links.c \
-                       ctf-visitor-semantic-validator.c \
-                       ctf-visitor-generate-io-struct.c \
-                       ctf-lexer.l ctf-parser.y
+libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y
+
+libctf_ast_la_SOURCES = ctf-visitor-xml.c \
+               ctf-visitor-parent-links.c \
+               ctf-visitor-semantic-validator.c \
+               ctf-visitor-generate-io-struct.c
+
+libctf_ast_la_LIBADD = \
+       $(top_builddir)/lib/libbabeltrace.la
+
+if BABELTRACE_BUILD_WITH_LIBUUID
+libctf_ast_la_LIBADD += -luuid
+endif
+if BABELTRACE_BUILD_WITH_LIBC_UUID
+libctf_ast_la_LIBADD += -lc
+endif
+
+noinst_PROGRAMS = ctf-parser-test
+ctf_parser_test_SOURCES = ctf-parser-test.c
+
+ctf_parser_test_LDADD = \
+               libctf-parser.la \
+               libctf-ast.la
This page took 0.024894 seconds and 4 git commands to generate.