Cleanup: Don't hardcode include paths unnecessarily
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index d54c12c125f27235b98e4eeb1b0a2fa903335139..cc67e9e03fb104ad45ff68d4b84b7f3e79f1a89a 100644 (file)
@@ -1,5 +1,5 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
-               -I$(top_srcdir)/formats/ctf/metadata
+               -I$(srcdir)
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
@@ -17,7 +17,7 @@ libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
 libctf_parser_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir) \
                -include $(srcdir)/ctf-scanner-symbols.h
 
-libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
+libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
                ctf-visitor-semantic-validator.c \
@@ -37,7 +37,7 @@ endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
-ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
+ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
This page took 0.022985 seconds and 4 git commands to generate.