Fix: lttng-live recv() and send() flags, partial recv()
[babeltrace.git] / formats / lttng-live / Makefile.am
index 8477927daa975a660212d08de0dfcedd87fe680b..c8346995277e07a6ce73fd13d536e07f0df7a91b 100644 (file)
@@ -2,8 +2,16 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_builddir)/include
 
 lib_LTLIBRARIES = libbabeltrace-lttng-live.la
 
+noinst_HEADERS = \
+                lttng-viewer-abi.h \
+                lttng-live.h
+
 libbabeltrace_lttng_live_la_SOURCES = \
-       lttng-live.c lttng-live-functions.c
+       lttng-live-plugin.c lttng-live-comm.c
+
+# Request that the linker keeps all static libraries objects.
+libbabeltrace_lttng_live_la_LDFLAGS = \
+       -Wl,--no-as-needed -version-info $(BABELTRACE_LIBRARY_VERSION)
 
 libbabeltrace_lttng_live_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
This page took 0.02614 seconds and 4 git commands to generate.