Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / formats / lttng-live / Makefile.am
index 775e9a56958477c822d7130ed5a9ac6eaafadf7c..d976979670dadd3a6f943d1e0f94465b1a77e305 100644 (file)
@@ -1,13 +1,17 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)
 
 lib_LTLIBRARIES = libbabeltrace-lttng-live.la
 
 noinst_HEADERS = \
                 lttng-viewer-abi.h \
-                lttng-live-functions.h
+                lttng-live.h
 
 libbabeltrace_lttng_live_la_SOURCES = \
-       lttng-live.c lttng-live-functions.c
+       lttng-live-plugin.c lttng-live-comm.c
+
+# Request that the linker keeps all static libraries objects.
+libbabeltrace_lttng_live_la_LDFLAGS = \
+       $(LD_NO_AS_NEEDED) -version-info $(BABELTRACE_LIBRARY_VERSION)
 
 libbabeltrace_lttng_live_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
This page took 0.023914 seconds and 4 git commands to generate.