Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / formats / lttng-live / Makefile.am
index c8346995277e07a6ce73fd13d536e07f0df7a91b..d976979670dadd3a6f943d1e0f94465b1a77e305 100644 (file)
@@ -1,4 +1,4 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)
 
 lib_LTLIBRARIES = libbabeltrace-lttng-live.la
 
@@ -11,7 +11,7 @@ libbabeltrace_lttng_live_la_SOURCES = \
 
 # Request that the linker keeps all static libraries objects.
 libbabeltrace_lttng_live_la_LDFLAGS = \
-       -Wl,--no-as-needed -version-info $(BABELTRACE_LIBRARY_VERSION)
+       $(LD_NO_AS_NEEDED) -version-info $(BABELTRACE_LIBRARY_VERSION)
 
 libbabeltrace_lttng_live_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
This page took 0.024353 seconds and 4 git commands to generate.