include/Makefile.am: add titles (comments) to groups of files
[babeltrace.git] / include / Makefile.am
index bcd1994acbaa0e4731d7d9f9f9baa03d9a98971d..1238144a9cbbf10b79b0090ecf99cb179561db21 100644 (file)
@@ -1,19 +1,15 @@
+# Core API
 babeltraceinclude_HEADERS = \
        babeltrace/babeltrace.h \
-       babeltrace/format.h \
-       babeltrace/context.h \
-       babeltrace/iterator.h \
-       babeltrace/trace-handle.h \
-       babeltrace/list.h \
-       babeltrace/clock-types.h \
        babeltrace/values.h \
-       babeltrace/ref.h
+       babeltrace/ref.h \
+       babeltrace/logging.h
 
+# Legacy API (for CTF writer)
 babeltracectfinclude_HEADERS = \
-       babeltrace/ctf/events.h \
-       babeltrace/ctf/callbacks.h \
-       babeltrace/ctf/iterator.h
+       babeltrace/ctf/events.h
 
+# CTF writer API
 babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/clock.h \
        babeltrace/ctf-writer/writer.h \
@@ -23,6 +19,7 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream.h \
        babeltrace/ctf-writer/stream-class.h
 
+# CTF IR API
 babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/clock-class.h \
        babeltrace/ctf-ir/fields.h \
@@ -37,99 +34,99 @@ babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/utils.h \
        babeltrace/ctf-ir/visitor.h
 
+# Plugin and plugin development API
 babeltraceplugininclude_HEADERS = \
        babeltrace/plugin/plugin.h \
        babeltrace/plugin/plugin-dev.h
 
-babeltracecomponentinclude_HEADERS = \
-       babeltrace/component/component.h \
-       babeltrace/component/component-class.h \
-       babeltrace/component/component-connection.h \
-       babeltrace/component/component-graph.h \
-       babeltrace/component/source.h \
-       babeltrace/component/sink.h \
-       babeltrace/component/filter.h \
-       babeltrace/component/notification/eot.h \
-       babeltrace/component/notification/notification.h \
-       babeltrace/component/notification/event.h \
-       babeltrace/component/notification/iterator.h \
-       babeltrace/component/notification/packet.h \
-       babeltrace/component/notification/schema.h \
-       babeltrace/component/notification/stream.h \
-       babeltrace/component/notification/heap.h
+# Graph, component, and notification API
+babeltracegraphinclude_HEADERS = \
+       babeltrace/graph/clock-class-priority-map.h \
+       babeltrace/graph/component-class-filter.h \
+       babeltrace/graph/component-class-sink.h \
+       babeltrace/graph/component-class-source.h \
+       babeltrace/graph/component-class.h \
+       babeltrace/graph/component-filter.h \
+       babeltrace/graph/component-sink.h \
+       babeltrace/graph/component-source.h \
+       babeltrace/graph/component-status.h \
+       babeltrace/graph/component.h \
+       babeltrace/graph/connection.h \
+       babeltrace/graph/graph.h \
+       babeltrace/graph/notification-event.h \
+       babeltrace/graph/notification-heap.h \
+       babeltrace/graph/notification-inactivity.h \
+       babeltrace/graph/notification-iterator.h \
+       babeltrace/graph/notification.h \
+       babeltrace/graph/notification-packet.h \
+       babeltrace/graph/notification-stream.h \
+       babeltrace/graph/port.h \
+       babeltrace/graph/private-component-filter.h \
+       babeltrace/graph/private-component-sink.h \
+       babeltrace/graph/private-component-source.h \
+       babeltrace/graph/private-component.h \
+       babeltrace/graph/private-connection.h \
+       babeltrace/graph/private-notification-iterator.h \
+       babeltrace/graph/private-port.h
 
 noinst_HEADERS = \
-       babeltrace/align.h \
+       babeltrace/align-internal.h \
        babeltrace/babeltrace-internal.h \
-       babeltrace/bitfield.h \
-       babeltrace/clock-internal.h \
-       babeltrace/compiler.h \
-       babeltrace/context-internal.h \
-       babeltrace/format-internal.h \
-       babeltrace/iterator-internal.h \
-       babeltrace/trace-collection.h \
-       babeltrace/prio_heap.h \
-       babeltrace/ref-internal.h \
-       babeltrace/types.h \
-       babeltrace/object-internal.h \
-       babeltrace/crc32.h \
-       babeltrace/debug-info.h \
-       babeltrace/trace-debug-info.h \
-       babeltrace/dwarf.h \
-       babeltrace/bin-info.h \
-       babeltrace/utils.h \
-       babeltrace/ctf-ir/metadata.h \
-       babeltrace/ctf/events-internal.h \
-       babeltrace/ctf/metadata.h \
-       babeltrace/ctf-text/types.h \
-       babeltrace/ctf/types.h \
-       babeltrace/ctf/callbacks-internal.h \
-       babeltrace/ctf/ctf-index.h \
-       babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/bitfield-internal.h \
+       babeltrace/common-internal.h \
+       babeltrace/compat/dirent-internal.h \
+       babeltrace/compat/fcntl-internal.h \
+       babeltrace/compat/glib-internal.h \
+       babeltrace/compat/limits-internal.h \
+       babeltrace/compat/memstream-internal.h \
+       babeltrace/compat/mman-internal.h \
+       babeltrace/compat/send-internal.h \
+       babeltrace/compat/stdio-internal.h \
+       babeltrace/compat/stdlib-internal.h \
+       babeltrace/compat/string-internal.h \
+       babeltrace/compat/utc-internal.h \
+       babeltrace/compat/uuid-internal.h \
+       babeltrace/compiler-internal.h \
        babeltrace/ctf-ir/attributes-internal.h \
-       babeltrace/ctf-ir/field-types-internal.h \
-       babeltrace/ctf-ir/fields-internal.h \
-       babeltrace/ctf-ir/event-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
        babeltrace/ctf-ir/event-class-internal.h \
+       babeltrace/ctf-ir/event-internal.h \
        babeltrace/ctf-ir/field-path-internal.h \
-       babeltrace/ctf-ir/clock-class-internal.h \
+       babeltrace/ctf-ir/field-types-internal.h \
+       babeltrace/ctf-ir/fields-internal.h \
+       babeltrace/ctf-ir/packet-internal.h \
        babeltrace/ctf-ir/resolve-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
-       babeltrace/ctf-ir/packet-internal.h \
        babeltrace/ctf-ir/trace-internal.h \
        babeltrace/ctf-ir/validation-internal.h \
        babeltrace/ctf-ir/visitor-internal.h \
        babeltrace/ctf-writer/clock-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
-       babeltrace/trace-handle-internal.h \
-       babeltrace/compat/uuid.h \
-       babeltrace/compat/memstream.h \
-       babeltrace/compat/string.h \
-       babeltrace/compat/utc.h \
-       babeltrace/compat/limits.h \
-       babeltrace/compat/glib.h \
-       babeltrace/compat/send.h \
-       babeltrace/compat/fcntl.h \
-       babeltrace/compat/stdlib.h \
-       babeltrace/compat/dirent.h \
-       babeltrace/compat/stdio.h \
-       babeltrace/compat/mman.h \
-       babeltrace/endian.h \
-       babeltrace/mmap-align.h \
+       babeltrace/ctf-writer/serialize-internal.h \
+       babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/endian-internal.h \
+       babeltrace/graph/clock-class-priority-map-internal.h \
+       babeltrace/graph/component-class-internal.h \
+       babeltrace/graph/component-filter-internal.h \
+       babeltrace/graph/component-internal.h \
+       babeltrace/graph/component-sink-internal.h \
+       babeltrace/graph/component-source-internal.h \
+       babeltrace/graph/connection-internal.h \
+       babeltrace/graph/graph-internal.h \
+       babeltrace/graph/notification-event-internal.h \
+       babeltrace/graph/notification-heap-internal.h \
+       babeltrace/graph/notification-inactivity-internal.h \
+       babeltrace/graph/notification-internal.h \
+       babeltrace/graph/notification-iterator-internal.h \
+       babeltrace/graph/notification-packet-internal.h \
+       babeltrace/graph/notification-stream-internal.h \
+       babeltrace/graph/port-internal.h \
+       babeltrace/lib-logging-internal.h \
+       babeltrace/logging-internal.h \
+       babeltrace/mmap-align-internal.h \
+       babeltrace/object-internal.h \
        babeltrace/plugin/plugin-internal.h \
-       babeltrace/component/component-class-internal.h \
-       babeltrace/component/component-connection-internal.h \
-       babeltrace/component/component-internal.h \
-       babeltrace/component/component-graph-internal.h \
-       babeltrace/component/filter-internal.h \
-       babeltrace/component/sink-internal.h \
-       babeltrace/component/source-internal.h \
-       babeltrace/component/input.h \
-       babeltrace/component/notification/eot-internal.h \
-       babeltrace/component/notification/event-internal.h \
-       babeltrace/component/notification/iterator-internal.h \
-       babeltrace/component/notification/notification-internal.h \
-       babeltrace/component/notification/packet-internal.h \
-       babeltrace/component/notification/stream-internal.h \
-       babeltrace/component/notification/heap-internal.h
+       babeltrace/plugin/plugin-so-internal.h \
+       babeltrace/prio-heap-internal.h \
+       babeltrace/ref-internal.h
This page took 0.024739 seconds and 4 git commands to generate.