Unify reference counting using a common bt_object base
[babeltrace.git] / include / Makefile.am
index 35af83ae1fb1e1758345420279b031431cc963ab..15159dd7a81d2fd1d84fc9c89a288adbe62a1434 100644 (file)
@@ -5,7 +5,9 @@ babeltraceinclude_HEADERS = \
        babeltrace/iterator.h \
        babeltrace/trace-handle.h \
        babeltrace/list.h \
-       babeltrace/clock-types.h
+       babeltrace/clock-types.h \
+       babeltrace/values.h \
+       babeltrace/ref.h
 
 babeltracectfinclude_HEADERS = \
        babeltrace/ctf/events.h \
@@ -28,7 +30,8 @@ babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/event.h \
        babeltrace/ctf-ir/stream.h \
        babeltrace/ctf-ir/stream-class.h \
-       babeltrace/ctf-ir/trace.h
+       babeltrace/ctf-ir/trace.h \
+       babeltrace/ctf-ir/utils.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
@@ -41,7 +44,9 @@ noinst_HEADERS = \
        babeltrace/iterator-internal.h \
        babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
+       babeltrace/ref-internal.h \
        babeltrace/types.h \
+       babeltrace/object-internal.h \
        babeltrace/ctf-ir/metadata.h \
        babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
@@ -49,14 +54,16 @@ noinst_HEADERS = \
        babeltrace/ctf/types.h \
        babeltrace/ctf/callbacks-internal.h \
        babeltrace/ctf/ctf-index.h \
-       babeltrace/ctf-writer/ref-internal.h \
        babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/ctf-ir/attributes-internal.h \
        babeltrace/ctf-ir/event-types-internal.h \
        babeltrace/ctf-ir/event-fields-internal.h \
        babeltrace/ctf-ir/event-internal.h \
        babeltrace/ctf-ir/clock-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
+       babeltrace/ctf-ir/trace-internal.h \
+       babeltrace/ctf-ir/visitor-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
This page took 0.024578 seconds and 4 git commands to generate.