Unify reference counting using a common bt_object base
[babeltrace.git] / include / Makefile.am
index ec927b9173ffa21f9a9557c157e80f5e38ba5d77..15159dd7a81d2fd1d84fc9c89a288adbe62a1434 100644 (file)
@@ -5,7 +5,9 @@ babeltraceinclude_HEADERS = \
        babeltrace/iterator.h \
        babeltrace/trace-handle.h \
        babeltrace/list.h \
-       babeltrace/clock-types.h
+       babeltrace/clock-types.h \
+       babeltrace/values.h \
+       babeltrace/ref.h
 
 babeltracectfinclude_HEADERS = \
        babeltrace/ctf/events.h \
@@ -18,7 +20,18 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/event-fields.h \
        babeltrace/ctf-writer/event-types.h \
        babeltrace/ctf-writer/event.h \
-       babeltrace/ctf-writer/stream.h
+       babeltrace/ctf-writer/stream.h \
+       babeltrace/ctf-writer/stream-class.h
+
+babeltracectfirinclude_HEADERS = \
+       babeltrace/ctf-ir/clock.h \
+       babeltrace/ctf-ir/event-fields.h \
+       babeltrace/ctf-ir/event-types.h \
+       babeltrace/ctf-ir/event.h \
+       babeltrace/ctf-ir/stream.h \
+       babeltrace/ctf-ir/stream-class.h \
+       babeltrace/ctf-ir/trace.h \
+       babeltrace/ctf-ir/utils.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
@@ -31,25 +44,32 @@ noinst_HEADERS = \
        babeltrace/iterator-internal.h \
        babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
+       babeltrace/ref-internal.h \
        babeltrace/types.h \
+       babeltrace/object-internal.h \
        babeltrace/ctf-ir/metadata.h \
        babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
        babeltrace/ctf-text/types.h \
        babeltrace/ctf/types.h \
        babeltrace/ctf/callbacks-internal.h \
-       babeltrace/ctf-writer/ref-internal.h \
+       babeltrace/ctf/ctf-index.h \
        babeltrace/ctf-writer/writer-internal.h \
-       babeltrace/ctf-writer/event-types-internal.h \
-       babeltrace/ctf-writer/event-fields-internal.h \
-       babeltrace/ctf-writer/event-internal.h \
-       babeltrace/ctf-writer/clock-internal.h \
-       babeltrace/ctf-writer/stream-internal.h \
+       babeltrace/ctf-ir/attributes-internal.h \
+       babeltrace/ctf-ir/event-types-internal.h \
+       babeltrace/ctf-ir/event-fields-internal.h \
+       babeltrace/ctf-ir/event-internal.h \
+       babeltrace/ctf-ir/clock-internal.h \
+       babeltrace/ctf-ir/stream-class-internal.h \
+       babeltrace/ctf-ir/stream-internal.h \
+       babeltrace/ctf-ir/trace-internal.h \
+       babeltrace/ctf-ir/visitor-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
        babeltrace/compat/memstream.h \
        babeltrace/compat/string.h \
        babeltrace/compat/utc.h \
+       babeltrace/compat/limits.h \
        babeltrace/endian.h \
        babeltrace/mmap-align.h
This page took 0.02594 seconds and 4 git commands to generate.