Initial implementation of the debuginfo API
[babeltrace.git] / include / Makefile.am
index eee2ac1048869435c326057966bfe6fcdf51e790..1f2b558af25c4493e149d18ef20eb2a596a86d19 100644 (file)
@@ -12,6 +12,14 @@ babeltracectfinclude_HEADERS = \
        babeltrace/ctf/callbacks.h \
        babeltrace/ctf/iterator.h
 
+babeltracectfwriterinclude_HEADERS = \
+       babeltrace/ctf-writer/clock.h \
+       babeltrace/ctf-writer/writer.h \
+       babeltrace/ctf-writer/event-fields.h \
+       babeltrace/ctf-writer/event-types.h \
+       babeltrace/ctf-writer/event.h \
+       babeltrace/ctf-writer/stream.h
+
 noinst_HEADERS = \
        babeltrace/align.h \
        babeltrace/babeltrace-internal.h \
@@ -24,14 +32,36 @@ noinst_HEADERS = \
        babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
        babeltrace/types.h \
+       babeltrace/crc32.h \
+       babeltrace/debuginfo.h \
+       babeltrace/trace-debuginfo.h \
+       babeltrace/dwarf.h \
+       babeltrace/so-info.h \
        babeltrace/ctf-ir/metadata.h \
        babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
        babeltrace/ctf-text/types.h \
        babeltrace/ctf/types.h \
        babeltrace/ctf/callbacks-internal.h \
+       babeltrace/ctf/ctf-index.h \
+       babeltrace/ctf-writer/ref-internal.h \
+       babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/ctf-writer/event-types-internal.h \
+       babeltrace/ctf-writer/event-fields-internal.h \
+       babeltrace/ctf-writer/event-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
+       babeltrace/ctf-writer/stream-internal.h \
+       babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
        babeltrace/compat/memstream.h \
+       babeltrace/compat/string.h \
+       babeltrace/compat/utc.h \
+       babeltrace/compat/limits.h \
+       babeltrace/compat/send.h \
+       babeltrace/compat/fcntl.h \
+       babeltrace/compat/stdlib.h \
+       babeltrace/compat/dirent.h \
+       babeltrace/compat/stdio.h \
        babeltrace/endian.h \
        babeltrace/mmap-align.h
This page took 0.0242 seconds and 4 git commands to generate.