Add limits compatibility header
[babeltrace.git] / include / Makefile.am
index 24826263aa496d20955f6d47a4fccbb95a74eb7a..8599efd7d3b8d792d9f21996df8ed15c84a7a781 100644 (file)
@@ -3,21 +3,33 @@ babeltraceinclude_HEADERS = \
        babeltrace/format.h \
        babeltrace/context.h \
        babeltrace/iterator.h \
-       babeltrace/trace-collection.h \
        babeltrace/trace-handle.h \
-       babeltrace/list.h
+       babeltrace/list.h \
+       babeltrace/clock-types.h
 
 babeltracectfinclude_HEADERS = \
-       babeltrace/ctf/events.h \
-       babeltrace/ctf/callbacks.h
+       babeltrace/ctf/events.h \
+       babeltrace/ctf/callbacks.h \
+       babeltrace/ctf/iterator.h
+
+babeltracectfwriterinclude_HEADERS = \
+       babeltrace/ctf-writer/clock.h \
+       babeltrace/ctf-writer/writer.h \
+       babeltrace/ctf-writer/event-fields.h \
+       babeltrace/ctf-writer/event-types.h \
+       babeltrace/ctf-writer/event.h \
+       babeltrace/ctf-writer/stream.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
        babeltrace/babeltrace-internal.h \
        babeltrace/bitfield.h \
+       babeltrace/clock-internal.h \
        babeltrace/compiler.h \
        babeltrace/context-internal.h \
+       babeltrace/format-internal.h \
        babeltrace/iterator-internal.h \
+       babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
        babeltrace/types.h \
        babeltrace/ctf-ir/metadata.h \
@@ -26,6 +38,20 @@ noinst_HEADERS = \
        babeltrace/ctf-text/types.h \
        babeltrace/ctf/types.h \
        babeltrace/ctf/callbacks-internal.h \
+       babeltrace/ctf/ctf-index.h \
+       babeltrace/ctf-writer/ref-internal.h \
+       babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/ctf-writer/event-types-internal.h \
+       babeltrace/ctf-writer/event-fields-internal.h \
+       babeltrace/ctf-writer/event-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
+       babeltrace/ctf-writer/stream-internal.h \
+       babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
-       babeltrace/uuid.h \
-       babeltrace/endian.h
+       babeltrace/compat/uuid.h \
+       babeltrace/compat/memstream.h \
+       babeltrace/compat/string.h \
+       babeltrace/compat/utc.h \
+       babeltrace/compat/limits.h \
+       babeltrace/endian.h \
+       babeltrace/mmap-align.h
This page took 0.023015 seconds and 4 git commands to generate.