Re-organize sources
[babeltrace.git] / include / Makefile.am
index a340b8052d835123f915ae1157071e4759806b0c..9b4f0530d6c4a77f6850b6c1c623d99da331df54 100644 (file)
@@ -1,73 +1,3 @@
-##
-## This target generates an include file that contains the git version
-## string of the current branch, it must be continuously updated when
-## we build in the git repo and shipped in dist tarballs to reflect the
-## status of the tree when it was generated. If the tree is clean and
-## the current commit is tag a starting with "v", consider this a
-## release version and set an empty git version.
-##
-## Here is what the inline script does:
-##
-## First, delete any stale "version.i.tmp" file.
-##
-## If "bootstrap" and ".git" exists in the top source directory and the git
-## executable is available, get the current git version string in the form:
-##
-##  "latest_tag"(-"number_of_commits_on_top")(-g"latest_commit_hash")(-dirty)
-##
-## And store it in "version.i.tmp", if the current commit is tagged, the tag
-## starts with "v" and the tree is clean, consider this a release version and
-## overwrite the git version with an empty string in "version.i.tmp".
-##
-## If we don't have a "version.i.tmp" nor a "version.i", generate an empty
-## string as a failover.
-##
-## If we don't have a "version.i" or we have both files and they are different,
-## copy "version.i.tmp" over "version.i". This way the dependent targets are
-## only rebuilt when the version string changes.
-##
-
-version_verbose = $(version_verbose_@AM_V@)
-version_verbose_ = $(version_verbose_@AM_DEFAULT_V@)
-version_verbose_0 = @echo "  GEN       " $@;
-
-version.i:
-       $(version_verbose)rm -f version.i.tmp; \
-       if (test -r "$(top_srcdir)/bootstrap" && test -r "$(top_srcdir)/.git") && \
-                       test -x "`which git 2>&1;true`"; then \
-               GIT_VERSION_STR="`cd "$(top_srcdir)" && git describe --tags --dirty`"; \
-               GIT_CURRENT_TAG="`cd "$(top_srcdir)" && git describe --tags --exact-match --match="v[0-9]*" HEAD 2> /dev/null`"; \
-               echo "#define GIT_VERSION \"$$GIT_VERSION_STR\"" > version.i.tmp; \
-               if ! $(GREP) -- "-dirty" version.i.tmp > /dev/null && \
-                               test "x$$GIT_CURRENT_TAG" != "x"; then \
-                       echo "#define GIT_VERSION \"\"" > version.i.tmp; \
-               fi; \
-       fi; \
-       if test ! -f version.i.tmp; then \
-               if test ! -f version.i; then \
-                       echo '#define GIT_VERSION ""' > version.i; \
-               fi; \
-       elif test ! -f version.i || \
-                       test x"`cat version.i.tmp`" != x"`cat version.i`"; then \
-               mv version.i.tmp version.i; \
-       fi; \
-       rm -f version.i.tmp; \
-       true
-
-##
-## version.i is defined as a .PHONY target even if it's a real file,
-## we want the target to be re-run on every make.
-##
-.PHONY: version.i
-
-CLEANFILES = version.i.tmp
-
-##
-## Only clean "version.i" on dist-clean, we need to keep it on regular
-## clean when it's part of a dist tarball.
-##
-DISTCLEANFILES = version.i
-
 # Core API
 babeltrace2includedir = "$(includedir)/babeltrace2"
 babeltrace2include_HEADERS = \
@@ -210,99 +140,3 @@ babeltrace2graphinclude_HEADERS = \
        babeltrace2/graph/self-component-source.h \
        babeltrace2/graph/self-component.h \
        babeltrace2/graph/self-message-iterator.h
-
-noinst_HEADERS = \
-       babeltrace2/compat/stdlib-internal.h \
-       babeltrace2/compat/fcntl-internal.h \
-       babeltrace2/compat/glib-internal.h \
-       babeltrace2/compat/uuid-internal.h \
-       babeltrace2/compat/unistd-internal.h \
-       babeltrace2/compat/stdio-internal.h \
-       babeltrace2/compat/time-internal.h \
-       babeltrace2/compat/utc-internal.h \
-       babeltrace2/compat/memstream-internal.h \
-       babeltrace2/compat/string-internal.h \
-       babeltrace2/compat/limits-internal.h \
-       babeltrace2/compat/mman-internal.h \
-       babeltrace2/compat/socket-internal.h \
-       babeltrace2/common-internal.h \
-       babeltrace2/ctfser-internal.h \
-       babeltrace2/bitfield-internal.h \
-       babeltrace2/object-internal.h \
-       babeltrace2/object-pool-internal.h \
-       babeltrace2/plugin/plugin-internal.h \
-       babeltrace2/plugin/plugin-so-internal.h \
-       babeltrace2/plugin/python-plugin-provider-internal.h \
-       babeltrace2/assert-internal.h \
-       babeltrace2/value-internal.h \
-       babeltrace2/ctf-writer/assert-pre-internal.h \
-       babeltrace2/ctf-writer/attributes-internal.h \
-       babeltrace2/ctf-writer/clock-class-internal.h \
-       babeltrace2/ctf-writer/clock-internal.h \
-       babeltrace2/ctf-writer/event-class-internal.h \
-       babeltrace2/ctf-writer/event-internal.h \
-       babeltrace2/ctf-writer/field-path-internal.h \
-       babeltrace2/ctf-writer/fields-internal.h \
-       babeltrace2/ctf-writer/field-types-internal.h \
-       babeltrace2/ctf-writer/field-wrapper-internal.h \
-       babeltrace2/ctf-writer/functor-internal.h \
-       babeltrace2/ctf-writer/object-internal.h \
-       babeltrace2/ctf-writer/object-pool-internal.h \
-       babeltrace2/ctf-writer/resolve-internal.h \
-       babeltrace2/ctf-writer/stream-class-internal.h \
-       babeltrace2/ctf-writer/stream-internal.h \
-       babeltrace2/ctf-writer/trace-internal.h \
-       babeltrace2/ctf-writer/utils-internal.h \
-       babeltrace2/ctf-writer/validation-internal.h \
-       babeltrace2/ctf-writer/values-internal.h \
-       babeltrace2/ctf-writer/visitor-internal.h \
-       babeltrace2/ctf-writer/writer-internal.h \
-       babeltrace2/mmap-align-internal.h \
-       babeltrace2/align-internal.h \
-       babeltrace2/logging-internal.h \
-       babeltrace2/endian-internal.h \
-       babeltrace2/trace-ir/attributes-internal.h \
-       babeltrace2/trace-ir/clock-class-internal.h \
-       babeltrace2/trace-ir/clock-snapshot-internal.h \
-       babeltrace2/trace-ir/clock-snapshot-set-internal.h \
-       babeltrace2/trace-ir/event-class-internal.h \
-       babeltrace2/trace-ir/event-internal.h \
-       babeltrace2/trace-ir/field-class-internal.h \
-       babeltrace2/trace-ir/field-path-internal.h \
-       babeltrace2/trace-ir/field-internal.h \
-       babeltrace2/trace-ir/field-wrapper-internal.h \
-       babeltrace2/trace-ir/packet-internal.h \
-       babeltrace2/trace-ir/resolve-field-path-internal.h \
-       babeltrace2/trace-ir/stream-class-internal.h \
-       babeltrace2/trace-ir/stream-internal.h \
-       babeltrace2/trace-ir/trace-class-internal.h \
-       babeltrace2/trace-ir/trace-internal.h \
-       babeltrace2/trace-ir/utils-internal.h \
-       babeltrace2/prio-heap-internal.h \
-       babeltrace2/lib-logging-internal.h \
-       babeltrace2/compiler-internal.h \
-       babeltrace2/babeltrace-internal.h \
-       babeltrace2/assert-pre-internal.h \
-       babeltrace2/graph/component-class-internal.h \
-       babeltrace2/graph/component-class-sink-colander-internal.h \
-       babeltrace2/graph/component-filter-internal.h \
-       babeltrace2/graph/component-internal.h \
-       babeltrace2/graph/component-sink-internal.h \
-       babeltrace2/graph/component-source-internal.h \
-       babeltrace2/graph/connection-internal.h \
-       babeltrace2/graph/graph-internal.h \
-       babeltrace2/graph/message-discarded-items-internal.h \
-       babeltrace2/graph/message-event-internal.h \
-       babeltrace2/graph/message-message-iterator-inactivity-internal.h \
-       babeltrace2/graph/message-internal.h \
-       babeltrace2/graph/message-iterator-internal.h \
-       babeltrace2/graph/message-packet-internal.h \
-       babeltrace2/graph/message-stream-activity-internal.h \
-       babeltrace2/graph/message-stream-internal.h \
-       babeltrace2/graph/port-internal.h \
-       babeltrace2/graph/query-executor-internal.h \
-       babeltrace2/list-internal.h \
-       babeltrace2/fd-cache-internal.h \
-       babeltrace2/property-internal.h \
-       version.h \
-       version.i
This page took 0.024015 seconds and 4 git commands to generate.