Add support for plugins written in Python
[babeltrace.git] / include / Makefile.am
index 3ce14183ef0fd3e516709b2a389223a1f024ba74..b05e6469ddd2e46334ded95d7af63e805ffe2082 100644 (file)
@@ -24,7 +24,7 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream-class.h
 
 babeltracectfirinclude_HEADERS = \
-       babeltrace/ctf-ir/clock.h \
+       babeltrace/ctf-ir/clock-class.h \
        babeltrace/ctf-ir/fields.h \
        babeltrace/ctf-ir/field-types.h \
        babeltrace/ctf-ir/event.h \
@@ -34,21 +34,34 @@ babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/packet.h \
        babeltrace/ctf-ir/stream-class.h \
        babeltrace/ctf-ir/trace.h \
-       babeltrace/ctf-ir/utils.h
+       babeltrace/ctf-ir/utils.h \
+       babeltrace/ctf-ir/visitor.h
 
 babeltraceplugininclude_HEADERS = \
        babeltrace/plugin/plugin.h \
-       babeltrace/plugin/component.h \
-       babeltrace/plugin/component-factory.h \
-       babeltrace/plugin/source.h \
-       babeltrace/plugin/sink.h \
-       babeltrace/plugin/filter.h \
-       babeltrace/plugin/plugin-system.h \
-       babeltrace/plugin/notification/eot.h \
-       babeltrace/plugin/notification/notification.h \
-       babeltrace/plugin/notification/event.h \
-       babeltrace/plugin/notification/iterator.h \
-       babeltrace/plugin/notification/packet.h
+       babeltrace/plugin/plugin-dev.h
+
+babeltracecomponentnotifinclude_HEADERS = \
+       babeltrace/component/notification/eot.h \
+       babeltrace/component/notification/notification.h \
+       babeltrace/component/notification/event.h \
+       babeltrace/component/notification/iterator.h \
+       babeltrace/component/notification/packet.h \
+       babeltrace/component/notification/schema.h \
+       babeltrace/component/notification/stream.h \
+       babeltrace/component/notification/heap.h
+
+babeltracecomponentinclude_HEADERS = \
+       babeltrace/component/component.h \
+       babeltrace/component/component-class.h \
+       babeltrace/component/component-class-source.h \
+       babeltrace/component/component-class-filter.h \
+       babeltrace/component/component-class-sink.h \
+       babeltrace/component/component-connection.h \
+       babeltrace/component/component-graph.h \
+       babeltrace/component/component-source.h \
+       babeltrace/component/component-sink.h \
+       babeltrace/component/component-filter.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
@@ -84,13 +97,15 @@ noinst_HEADERS = \
        babeltrace/ctf-ir/event-internal.h \
        babeltrace/ctf-ir/event-class-internal.h \
        babeltrace/ctf-ir/field-path-internal.h \
-       babeltrace/ctf-ir/clock-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
        babeltrace/ctf-ir/resolve-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
        babeltrace/ctf-ir/packet-internal.h \
        babeltrace/ctf-ir/trace-internal.h \
        babeltrace/ctf-ir/validation-internal.h \
+       babeltrace/ctf-ir/visitor-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
@@ -107,15 +122,22 @@ noinst_HEADERS = \
        babeltrace/compat/mman.h \
        babeltrace/endian.h \
        babeltrace/mmap-align.h \
-       babeltrace/plugin/component-factory-internal.h \
-       babeltrace/plugin/component-internal.h \
-       babeltrace/plugin/component-class-internal.h \
        babeltrace/plugin/plugin-internal.h \
-       babeltrace/plugin/filter-internal.h \
-       babeltrace/plugin/sink-internal.h \
-       babeltrace/plugin/source-internal.h \
-       babeltrace/plugin/notification/eot-internal.h \
-       babeltrace/plugin/notification/event-internal.h \
-       babeltrace/plugin/notification/iterator-internal.h \
-       babeltrace/plugin/notification/notification-internal.h \
-       babeltrace/plugin/notification/packet-internal.h
+       babeltrace/plugin/plugin-so-internal.h \
+       babeltrace/plugin/plugin-python-enabled-internal.h \
+       babeltrace/plugin/plugin-python-disabled-internal.h \
+       babeltrace/component/component-class-internal.h \
+       babeltrace/component/component-connection-internal.h \
+       babeltrace/component/component-internal.h \
+       babeltrace/component/component-graph-internal.h \
+       babeltrace/component/component-filter-internal.h \
+       babeltrace/component/component-sink-internal.h \
+       babeltrace/component/component-source-internal.h \
+       babeltrace/component/component-input-internal.h \
+       babeltrace/component/notification/eot-internal.h \
+       babeltrace/component/notification/event-internal.h \
+       babeltrace/component/notification/iterator-internal.h \
+       babeltrace/component/notification/notification-internal.h \
+       babeltrace/component/notification/packet-internal.h \
+       babeltrace/component/notification/stream-internal.h \
+       babeltrace/component/notification/heap-internal.h
This page took 0.025575 seconds and 4 git commands to generate.