Put Python plugin support in a separate shared object
[babeltrace.git] / include / Makefile.am
index 15159dd7a81d2fd1d84fc9c89a288adbe62a1434..b4d86eccea81ecec546c50dacbc831f7bf4f5674 100644 (file)
@@ -24,20 +24,52 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream-class.h
 
 babeltracectfirinclude_HEADERS = \
-       babeltrace/ctf-ir/clock.h \
-       babeltrace/ctf-ir/event-fields.h \
-       babeltrace/ctf-ir/event-types.h \
+       babeltrace/ctf-ir/clock-class.h \
+       babeltrace/ctf-ir/fields.h \
+       babeltrace/ctf-ir/field-types.h \
        babeltrace/ctf-ir/event.h \
+       babeltrace/ctf-ir/event-class.h \
+       babeltrace/ctf-ir/field-path.h \
        babeltrace/ctf-ir/stream.h \
+       babeltrace/ctf-ir/packet.h \
        babeltrace/ctf-ir/stream-class.h \
        babeltrace/ctf-ir/trace.h \
-       babeltrace/ctf-ir/utils.h
+       babeltrace/ctf-ir/utils.h \
+       babeltrace/ctf-ir/visitor.h
+
+babeltraceplugininclude_HEADERS = \
+       babeltrace/plugin/plugin.h \
+       babeltrace/plugin/plugin-dev.h
+
+babeltracecomponentnotifinclude_HEADERS = \
+       babeltrace/component/notification/eot.h \
+       babeltrace/component/notification/notification.h \
+       babeltrace/component/notification/event.h \
+       babeltrace/component/notification/iterator.h \
+       babeltrace/component/notification/packet.h \
+       babeltrace/component/notification/schema.h \
+       babeltrace/component/notification/stream.h \
+       babeltrace/component/notification/heap.h
+
+babeltracecomponentinclude_HEADERS = \
+       babeltrace/component/component.h \
+       babeltrace/component/component-class.h \
+       babeltrace/component/component-class-source.h \
+       babeltrace/component/component-class-filter.h \
+       babeltrace/component/component-class-sink.h \
+       babeltrace/component/connection.h \
+       babeltrace/component/port.h \
+       babeltrace/component/graph.h \
+       babeltrace/component/component-source.h \
+       babeltrace/component/component-sink.h \
+       babeltrace/component/component-filter.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
        babeltrace/babeltrace-internal.h \
        babeltrace/bitfield.h \
        babeltrace/clock-internal.h \
+       babeltrace/common-internal.h \
        babeltrace/compiler.h \
        babeltrace/context-internal.h \
        babeltrace/format-internal.h \
@@ -47,6 +79,12 @@ noinst_HEADERS = \
        babeltrace/ref-internal.h \
        babeltrace/types.h \
        babeltrace/object-internal.h \
+       babeltrace/crc32.h \
+       babeltrace/debug-info.h \
+       babeltrace/trace-debug-info.h \
+       babeltrace/dwarf.h \
+       babeltrace/bin-info.h \
+       babeltrace/utils.h \
        babeltrace/ctf-ir/metadata.h \
        babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
@@ -56,14 +94,20 @@ noinst_HEADERS = \
        babeltrace/ctf/ctf-index.h \
        babeltrace/ctf-writer/writer-internal.h \
        babeltrace/ctf-ir/attributes-internal.h \
-       babeltrace/ctf-ir/event-types-internal.h \
-       babeltrace/ctf-ir/event-fields-internal.h \
+       babeltrace/ctf-ir/field-types-internal.h \
+       babeltrace/ctf-ir/fields-internal.h \
        babeltrace/ctf-ir/event-internal.h \
-       babeltrace/ctf-ir/clock-internal.h \
+       babeltrace/ctf-ir/event-class-internal.h \
+       babeltrace/ctf-ir/field-path-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
+       babeltrace/ctf-ir/resolve-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
+       babeltrace/ctf-ir/packet-internal.h \
        babeltrace/ctf-ir/trace-internal.h \
+       babeltrace/ctf-ir/validation-internal.h \
        babeltrace/ctf-ir/visitor-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
@@ -71,5 +115,29 @@ noinst_HEADERS = \
        babeltrace/compat/string.h \
        babeltrace/compat/utc.h \
        babeltrace/compat/limits.h \
+       babeltrace/compat/glib.h \
+       babeltrace/compat/send.h \
+       babeltrace/compat/fcntl.h \
+       babeltrace/compat/stdlib.h \
+       babeltrace/compat/dirent.h \
+       babeltrace/compat/stdio.h \
+       babeltrace/compat/mman.h \
        babeltrace/endian.h \
-       babeltrace/mmap-align.h
+       babeltrace/mmap-align.h \
+       babeltrace/plugin/plugin-internal.h \
+       babeltrace/plugin/plugin-so-internal.h \
+       babeltrace/component/component-class-internal.h \
+       babeltrace/component/connection-internal.h \
+       babeltrace/component/port-internal.h \
+       babeltrace/component/component-internal.h \
+       babeltrace/component/graph-internal.h \
+       babeltrace/component/component-filter-internal.h \
+       babeltrace/component/component-sink-internal.h \
+       babeltrace/component/component-source-internal.h \
+       babeltrace/component/notification/eot-internal.h \
+       babeltrace/component/notification/event-internal.h \
+       babeltrace/component/notification/iterator-internal.h \
+       babeltrace/component/notification/notification-internal.h \
+       babeltrace/component/notification/packet-internal.h \
+       babeltrace/component/notification/stream-internal.h \
+       babeltrace/component/notification/heap-internal.h
This page took 0.023858 seconds and 4 git commands to generate.