Put Python plugin support in a separate shared object
[babeltrace.git] / include / Makefile.am
index d839f478a55ad323b539477928805dc2bf5af71f..b4d86eccea81ecec546c50dacbc831f7bf4f5674 100644 (file)
@@ -24,7 +24,7 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream-class.h
 
 babeltracectfirinclude_HEADERS = \
-       babeltrace/ctf-ir/clock.h \
+       babeltrace/ctf-ir/clock-class.h \
        babeltrace/ctf-ir/fields.h \
        babeltrace/ctf-ir/field-types.h \
        babeltrace/ctf-ir/event.h \
@@ -34,26 +34,42 @@ babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/packet.h \
        babeltrace/ctf-ir/stream-class.h \
        babeltrace/ctf-ir/trace.h \
-       babeltrace/ctf-ir/utils.h
+       babeltrace/ctf-ir/utils.h \
+       babeltrace/ctf-ir/visitor.h
 
 babeltraceplugininclude_HEADERS = \
        babeltrace/plugin/plugin.h \
-       babeltrace/plugin/source.h \
-       babeltrace/plugin/sink.h \
-       babeltrace/plugin/filter.h \
-       babeltrace/plugin/plugin-lib.h \
-       babeltrace/plugin/plugin-system.h \
-       babeltrace/plugin/notification/notification.h \
-       babeltrace/plugin/notification/event.h \
-       babeltrace/plugin/notification/eot.h \
-       babeltrace/plugin/notification/iterator.h \
-       babeltrace/plugin/notification/packet.h
+       babeltrace/plugin/plugin-dev.h
+
+babeltracecomponentnotifinclude_HEADERS = \
+       babeltrace/component/notification/eot.h \
+       babeltrace/component/notification/notification.h \
+       babeltrace/component/notification/event.h \
+       babeltrace/component/notification/iterator.h \
+       babeltrace/component/notification/packet.h \
+       babeltrace/component/notification/schema.h \
+       babeltrace/component/notification/stream.h \
+       babeltrace/component/notification/heap.h
+
+babeltracecomponentinclude_HEADERS = \
+       babeltrace/component/component.h \
+       babeltrace/component/component-class.h \
+       babeltrace/component/component-class-source.h \
+       babeltrace/component/component-class-filter.h \
+       babeltrace/component/component-class-sink.h \
+       babeltrace/component/connection.h \
+       babeltrace/component/port.h \
+       babeltrace/component/graph.h \
+       babeltrace/component/component-source.h \
+       babeltrace/component/component-sink.h \
+       babeltrace/component/component-filter.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
        babeltrace/babeltrace-internal.h \
        babeltrace/bitfield.h \
        babeltrace/clock-internal.h \
+       babeltrace/common-internal.h \
        babeltrace/compiler.h \
        babeltrace/context-internal.h \
        babeltrace/format-internal.h \
@@ -83,13 +99,15 @@ noinst_HEADERS = \
        babeltrace/ctf-ir/event-internal.h \
        babeltrace/ctf-ir/event-class-internal.h \
        babeltrace/ctf-ir/field-path-internal.h \
-       babeltrace/ctf-ir/clock-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
        babeltrace/ctf-ir/resolve-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
        babeltrace/ctf-ir/packet-internal.h \
        babeltrace/ctf-ir/trace-internal.h \
        babeltrace/ctf-ir/validation-internal.h \
+       babeltrace/ctf-ir/visitor-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
@@ -107,9 +125,19 @@ noinst_HEADERS = \
        babeltrace/endian.h \
        babeltrace/mmap-align.h \
        babeltrace/plugin/plugin-internal.h \
-       babeltrace/plugin/sink-internal.h \
-       babeltrace/plugin/source-internal.h \
-       babeltrace/plugin/filter-internal.h \
-       babeltrace/plugin/notification/event-internal.h \
-       babeltrace/plugin/notification/notification-internal.h \
-       babeltrace/plugin/notification/iterator-internal.h
+       babeltrace/plugin/plugin-so-internal.h \
+       babeltrace/component/component-class-internal.h \
+       babeltrace/component/connection-internal.h \
+       babeltrace/component/port-internal.h \
+       babeltrace/component/component-internal.h \
+       babeltrace/component/graph-internal.h \
+       babeltrace/component/component-filter-internal.h \
+       babeltrace/component/component-sink-internal.h \
+       babeltrace/component/component-source-internal.h \
+       babeltrace/component/notification/eot-internal.h \
+       babeltrace/component/notification/event-internal.h \
+       babeltrace/component/notification/iterator-internal.h \
+       babeltrace/component/notification/notification-internal.h \
+       babeltrace/component/notification/packet-internal.h \
+       babeltrace/component/notification/stream-internal.h \
+       babeltrace/component/notification/heap-internal.h
This page took 0.024077 seconds and 4 git commands to generate.