Decouple component class from plugin subsystem, remove component factory
[babeltrace.git] / include / Makefile.am
index d9996a7b4cf93b679cb1133e4ba80b106bd611fe..bcd1994acbaa0e4731d7d9f9f9baa03d9a98971d 100644 (file)
@@ -5,7 +5,9 @@ babeltraceinclude_HEADERS = \
        babeltrace/iterator.h \
        babeltrace/trace-handle.h \
        babeltrace/list.h \
-       babeltrace/clock-types.h
+       babeltrace/clock-types.h \
+       babeltrace/values.h \
+       babeltrace/ref.h
 
 babeltracectfinclude_HEADERS = \
        babeltrace/ctf/events.h \
@@ -18,7 +20,43 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/event-fields.h \
        babeltrace/ctf-writer/event-types.h \
        babeltrace/ctf-writer/event.h \
-       babeltrace/ctf-writer/stream.h
+       babeltrace/ctf-writer/stream.h \
+       babeltrace/ctf-writer/stream-class.h
+
+babeltracectfirinclude_HEADERS = \
+       babeltrace/ctf-ir/clock-class.h \
+       babeltrace/ctf-ir/fields.h \
+       babeltrace/ctf-ir/field-types.h \
+       babeltrace/ctf-ir/event.h \
+       babeltrace/ctf-ir/event-class.h \
+       babeltrace/ctf-ir/field-path.h \
+       babeltrace/ctf-ir/stream.h \
+       babeltrace/ctf-ir/packet.h \
+       babeltrace/ctf-ir/stream-class.h \
+       babeltrace/ctf-ir/trace.h \
+       babeltrace/ctf-ir/utils.h \
+       babeltrace/ctf-ir/visitor.h
+
+babeltraceplugininclude_HEADERS = \
+       babeltrace/plugin/plugin.h \
+       babeltrace/plugin/plugin-dev.h
+
+babeltracecomponentinclude_HEADERS = \
+       babeltrace/component/component.h \
+       babeltrace/component/component-class.h \
+       babeltrace/component/component-connection.h \
+       babeltrace/component/component-graph.h \
+       babeltrace/component/source.h \
+       babeltrace/component/sink.h \
+       babeltrace/component/filter.h \
+       babeltrace/component/notification/eot.h \
+       babeltrace/component/notification/notification.h \
+       babeltrace/component/notification/event.h \
+       babeltrace/component/notification/iterator.h \
+       babeltrace/component/notification/packet.h \
+       babeltrace/component/notification/schema.h \
+       babeltrace/component/notification/stream.h \
+       babeltrace/component/notification/heap.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
@@ -31,7 +69,15 @@ noinst_HEADERS = \
        babeltrace/iterator-internal.h \
        babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
+       babeltrace/ref-internal.h \
        babeltrace/types.h \
+       babeltrace/object-internal.h \
+       babeltrace/crc32.h \
+       babeltrace/debug-info.h \
+       babeltrace/trace-debug-info.h \
+       babeltrace/dwarf.h \
+       babeltrace/bin-info.h \
+       babeltrace/utils.h \
        babeltrace/ctf-ir/metadata.h \
        babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
@@ -39,18 +85,51 @@ noinst_HEADERS = \
        babeltrace/ctf/types.h \
        babeltrace/ctf/callbacks-internal.h \
        babeltrace/ctf/ctf-index.h \
-       babeltrace/ctf-writer/ref-internal.h \
        babeltrace/ctf-writer/writer-internal.h \
-       babeltrace/ctf-writer/event-types-internal.h \
-       babeltrace/ctf-writer/event-fields-internal.h \
-       babeltrace/ctf-writer/event-internal.h \
+       babeltrace/ctf-ir/attributes-internal.h \
+       babeltrace/ctf-ir/field-types-internal.h \
+       babeltrace/ctf-ir/fields-internal.h \
+       babeltrace/ctf-ir/event-internal.h \
+       babeltrace/ctf-ir/event-class-internal.h \
+       babeltrace/ctf-ir/field-path-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
+       babeltrace/ctf-ir/resolve-internal.h \
+       babeltrace/ctf-ir/stream-class-internal.h \
+       babeltrace/ctf-ir/stream-internal.h \
+       babeltrace/ctf-ir/packet-internal.h \
+       babeltrace/ctf-ir/trace-internal.h \
+       babeltrace/ctf-ir/validation-internal.h \
+       babeltrace/ctf-ir/visitor-internal.h \
        babeltrace/ctf-writer/clock-internal.h \
-       babeltrace/ctf-writer/stream-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
        babeltrace/compat/memstream.h \
        babeltrace/compat/string.h \
        babeltrace/compat/utc.h \
+       babeltrace/compat/limits.h \
+       babeltrace/compat/glib.h \
+       babeltrace/compat/send.h \
+       babeltrace/compat/fcntl.h \
+       babeltrace/compat/stdlib.h \
+       babeltrace/compat/dirent.h \
+       babeltrace/compat/stdio.h \
+       babeltrace/compat/mman.h \
        babeltrace/endian.h \
-       babeltrace/mmap-align.h
+       babeltrace/mmap-align.h \
+       babeltrace/plugin/plugin-internal.h \
+       babeltrace/component/component-class-internal.h \
+       babeltrace/component/component-connection-internal.h \
+       babeltrace/component/component-internal.h \
+       babeltrace/component/component-graph-internal.h \
+       babeltrace/component/filter-internal.h \
+       babeltrace/component/sink-internal.h \
+       babeltrace/component/source-internal.h \
+       babeltrace/component/input.h \
+       babeltrace/component/notification/eot-internal.h \
+       babeltrace/component/notification/event-internal.h \
+       babeltrace/component/notification/iterator-internal.h \
+       babeltrace/component/notification/notification-internal.h \
+       babeltrace/component/notification/packet-internal.h \
+       babeltrace/component/notification/stream-internal.h \
+       babeltrace/component/notification/heap-internal.h
This page took 0.024204 seconds and 4 git commands to generate.