Decouple component class from plugin subsystem, remove component factory
[babeltrace.git] / include / Makefile.am
index ecdb36326cbea14e2cdb985d0dd83f481bbc5b67..bcd1994acbaa0e4731d7d9f9f9baa03d9a98971d 100644 (file)
@@ -24,7 +24,7 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream-class.h
 
 babeltracectfirinclude_HEADERS = \
-       babeltrace/ctf-ir/clock.h \
+       babeltrace/ctf-ir/clock-class.h \
        babeltrace/ctf-ir/fields.h \
        babeltrace/ctf-ir/field-types.h \
        babeltrace/ctf-ir/event.h \
@@ -39,20 +39,24 @@ babeltracectfirinclude_HEADERS = \
 
 babeltraceplugininclude_HEADERS = \
        babeltrace/plugin/plugin.h \
-       babeltrace/plugin/component.h \
-       babeltrace/plugin/component-class.h \
-       babeltrace/plugin/component-factory.h \
-       babeltrace/plugin/source.h \
-       babeltrace/plugin/sink.h \
-       babeltrace/plugin/filter.h \
-       babeltrace/plugin/plugin-system.h \
-       babeltrace/plugin/notification/eot.h \
-       babeltrace/plugin/notification/notification.h \
-       babeltrace/plugin/notification/event.h \
-       babeltrace/plugin/notification/iterator.h \
-       babeltrace/plugin/notification/packet.h \
-       babeltrace/plugin/notification/schema.h \
-       babeltrace/plugin/notification/stream.h
+       babeltrace/plugin/plugin-dev.h
+
+babeltracecomponentinclude_HEADERS = \
+       babeltrace/component/component.h \
+       babeltrace/component/component-class.h \
+       babeltrace/component/component-connection.h \
+       babeltrace/component/component-graph.h \
+       babeltrace/component/source.h \
+       babeltrace/component/sink.h \
+       babeltrace/component/filter.h \
+       babeltrace/component/notification/eot.h \
+       babeltrace/component/notification/notification.h \
+       babeltrace/component/notification/event.h \
+       babeltrace/component/notification/iterator.h \
+       babeltrace/component/notification/packet.h \
+       babeltrace/component/notification/schema.h \
+       babeltrace/component/notification/stream.h \
+       babeltrace/component/notification/heap.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
@@ -88,7 +92,7 @@ noinst_HEADERS = \
        babeltrace/ctf-ir/event-internal.h \
        babeltrace/ctf-ir/event-class-internal.h \
        babeltrace/ctf-ir/field-path-internal.h \
-       babeltrace/ctf-ir/clock-internal.h \
+       babeltrace/ctf-ir/clock-class-internal.h \
        babeltrace/ctf-ir/resolve-internal.h \
        babeltrace/ctf-ir/stream-class-internal.h \
        babeltrace/ctf-ir/stream-internal.h \
@@ -96,6 +100,7 @@ noinst_HEADERS = \
        babeltrace/ctf-ir/trace-internal.h \
        babeltrace/ctf-ir/validation-internal.h \
        babeltrace/ctf-ir/visitor-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
        babeltrace/ctf-writer/functor-internal.h \
        babeltrace/trace-handle-internal.h \
        babeltrace/compat/uuid.h \
@@ -112,17 +117,19 @@ noinst_HEADERS = \
        babeltrace/compat/mman.h \
        babeltrace/endian.h \
        babeltrace/mmap-align.h \
-       babeltrace/plugin/component-factory-internal.h \
-       babeltrace/plugin/component-internal.h \
-       babeltrace/plugin/component-class-internal.h \
        babeltrace/plugin/plugin-internal.h \
-       babeltrace/plugin/filter-internal.h \
-       babeltrace/plugin/sink-internal.h \
-       babeltrace/plugin/source-internal.h \
-       babeltrace/plugin/input.h \
-       babeltrace/plugin/notification/eot-internal.h \
-       babeltrace/plugin/notification/event-internal.h \
-       babeltrace/plugin/notification/iterator-internal.h \
-       babeltrace/plugin/notification/notification-internal.h \
-       babeltrace/plugin/notification/packet-internal.h \
-       babeltrace/plugin/notification/stream-internal.h
+       babeltrace/component/component-class-internal.h \
+       babeltrace/component/component-connection-internal.h \
+       babeltrace/component/component-internal.h \
+       babeltrace/component/component-graph-internal.h \
+       babeltrace/component/filter-internal.h \
+       babeltrace/component/sink-internal.h \
+       babeltrace/component/source-internal.h \
+       babeltrace/component/input.h \
+       babeltrace/component/notification/eot-internal.h \
+       babeltrace/component/notification/event-internal.h \
+       babeltrace/component/notification/iterator-internal.h \
+       babeltrace/component/notification/notification-internal.h \
+       babeltrace/component/notification/packet-internal.h \
+       babeltrace/component/notification/stream-internal.h \
+       babeltrace/component/notification/heap-internal.h
This page took 0.024598 seconds and 4 git commands to generate.