Python bindings: add has_intersection property to TraceCollection
[babeltrace.git] / include / Makefile.am
index 70cdd2a18320793035c8a6018ca8d757e85db247..eb58604a91cd7728443fb2e61889166ce91af3ec 100644 (file)
@@ -1,19 +1,68 @@
 babeltraceinclude_HEADERS = \
        babeltrace/babeltrace.h \
-       babeltrace/format.h
+       babeltrace/format.h \
+       babeltrace/context.h \
+       babeltrace/iterator.h \
+       babeltrace/trace-handle.h \
+       babeltrace/list.h \
+       babeltrace/clock-types.h
+
+babeltracectfinclude_HEADERS = \
+       babeltrace/ctf/events.h \
+       babeltrace/ctf/callbacks.h \
+       babeltrace/ctf/iterator.h
 
+babeltracectfwriterinclude_HEADERS = \
+       babeltrace/ctf-writer/clock.h \
+       babeltrace/ctf-writer/writer.h \
+       babeltrace/ctf-writer/event-fields.h \
+       babeltrace/ctf-writer/event-types.h \
+       babeltrace/ctf-writer/event.h \
+       babeltrace/ctf-writer/stream.h
 
 noinst_HEADERS = \
        babeltrace/align.h \
        babeltrace/babeltrace-internal.h \
        babeltrace/bitfield.h \
-       babeltrace/callbacks-internal.h \
+       babeltrace/clock-internal.h \
        babeltrace/compiler.h \
+       babeltrace/context-internal.h \
+       babeltrace/format-internal.h \
        babeltrace/iterator-internal.h \
-       babeltrace/list.h \
+       babeltrace/trace-collection.h \
        babeltrace/prio_heap.h \
        babeltrace/types.h \
+       babeltrace/crc32.h \
+       babeltrace/debuginfo.h \
+       babeltrace/trace-debuginfo.h \
+       babeltrace/dwarf.h \
+       babeltrace/bin-info.h \
+       babeltrace/utils.h \
        babeltrace/ctf-ir/metadata.h \
+       babeltrace/ctf/events-internal.h \
        babeltrace/ctf/metadata.h \
        babeltrace/ctf-text/types.h \
-       babeltrace/ctf/types.h
+       babeltrace/ctf/types.h \
+       babeltrace/ctf/callbacks-internal.h \
+       babeltrace/ctf/ctf-index.h \
+       babeltrace/ctf-writer/ref-internal.h \
+       babeltrace/ctf-writer/writer-internal.h \
+       babeltrace/ctf-writer/event-types-internal.h \
+       babeltrace/ctf-writer/event-fields-internal.h \
+       babeltrace/ctf-writer/event-internal.h \
+       babeltrace/ctf-writer/clock-internal.h \
+       babeltrace/ctf-writer/stream-internal.h \
+       babeltrace/ctf-writer/functor-internal.h \
+       babeltrace/trace-handle-internal.h \
+       babeltrace/compat/uuid.h \
+       babeltrace/compat/memstream.h \
+       babeltrace/compat/string.h \
+       babeltrace/compat/utc.h \
+       babeltrace/compat/limits.h \
+       babeltrace/compat/send.h \
+       babeltrace/compat/fcntl.h \
+       babeltrace/compat/stdlib.h \
+       babeltrace/compat/dirent.h \
+       babeltrace/compat/stdio.h \
+       babeltrace/endian.h \
+       babeltrace/mmap-align.h
This page took 0.022961 seconds and 4 git commands to generate.