bt2: make bt2.Error wrap current thread's error
[babeltrace.git] / include / Makefile.am
index 4507108363d10238573902fa623370292e393656..f04512201d40db75b5845a81ef9cbdcf84661dbb 100644 (file)
@@ -2,55 +2,38 @@
 babeltrace2includedir = "$(includedir)/babeltrace2"
 babeltrace2include_HEADERS = \
        babeltrace2/babeltrace.h \
-       babeltrace2/func-status.h \
        babeltrace2/current-thread.h \
        babeltrace2/error-cause-const.h \
        babeltrace2/error-const.h \
+       babeltrace2/func-status.h \
+       babeltrace2/integer-range-set-const.h \
+       babeltrace2/integer-range-set.h \
        babeltrace2/logging.h \
        babeltrace2/property.h \
        babeltrace2/types.h \
-       babeltrace2/undef-func-status.h \
        babeltrace2/util.h \
        babeltrace2/value-const.h \
        babeltrace2/value.h \
        babeltrace2/version.h
 
-# Legacy API (for CTF writer)
-babeltrace2ctfincludedir = "$(includedir)/babeltrace2/ctf"
-babeltrace2ctfinclude_HEADERS = \
-       babeltrace2/ctf/events.h
-
 # CTF writer API
-babeltrace2ctfwriterincludedir = "$(includedir)/babeltrace2/ctf-writer"
+babeltrace2ctfwriterincludedir = "$(includedir)/babeltrace2-ctf-writer"
 babeltrace2ctfwriterinclude_HEADERS = \
-       babeltrace2/ctf-writer/clock-class.h \
-       babeltrace2/ctf-writer/clock.h \
-       babeltrace2/ctf-writer/event-fields.h \
-       babeltrace2/ctf-writer/event-types.h \
-       babeltrace2/ctf-writer/event.h \
-       babeltrace2/ctf-writer/field-types.h \
-       babeltrace2/ctf-writer/fields.h \
-       babeltrace2/ctf-writer/object.h \
-       babeltrace2/ctf-writer/stream-class.h \
-       babeltrace2/ctf-writer/stream.h \
-       babeltrace2/ctf-writer/trace.h \
-       babeltrace2/ctf-writer/utils.h \
-       babeltrace2/ctf-writer/visitor.h \
-       babeltrace2/ctf-writer/writer.h
-
-# Legacy API (for CTF writer)
-babeltrace2ctfirincludedir = "$(includedir)/babeltrace2/ctf-ir"
-babeltrace2ctfirinclude_HEADERS = \
-       babeltrace2/ctf-ir/clock.h \
-       babeltrace2/ctf-ir/event-fields.h \
-       babeltrace2/ctf-ir/event-types.h \
-       babeltrace2/ctf-ir/event.h \
-       babeltrace2/ctf-ir/field-types.h \
-       babeltrace2/ctf-ir/fields.h \
-       babeltrace2/ctf-ir/stream-class.h \
-       babeltrace2/ctf-ir/stream.h \
-       babeltrace2/ctf-ir/trace.h \
-       babeltrace2/ctf-ir/utils.h
+       babeltrace2-ctf-writer/clock-class.h \
+       babeltrace2-ctf-writer/clock.h \
+       babeltrace2-ctf-writer/event-fields.h \
+       babeltrace2-ctf-writer/event-types.h \
+       babeltrace2-ctf-writer/event.h \
+       babeltrace2-ctf-writer/field-types.h \
+       babeltrace2-ctf-writer/fields.h \
+       babeltrace2-ctf-writer/object.h \
+       babeltrace2-ctf-writer/stream-class.h \
+       babeltrace2-ctf-writer/stream.h \
+       babeltrace2-ctf-writer/trace.h \
+       babeltrace2-ctf-writer/types.h \
+       babeltrace2-ctf-writer/utils.h \
+       babeltrace2-ctf-writer/visitor.h \
+       babeltrace2-ctf-writer/writer.h
 
 # Trace IR API
 babeltrace2traceirincludedir = "$(includedir)/babeltrace2/trace-ir"
@@ -118,13 +101,9 @@ babeltrace2graphinclude_HEADERS = \
        babeltrace2/graph/message-packet-beginning.h \
        babeltrace2/graph/message-packet-end-const.h \
        babeltrace2/graph/message-packet-end.h \
-       babeltrace2/graph/message-stream-activity-beginning-const.h \
-       babeltrace2/graph/message-stream-activity-beginning.h \
-       babeltrace2/graph/message-stream-activity-const.h \
-       babeltrace2/graph/message-stream-activity-end-const.h \
-       babeltrace2/graph/message-stream-activity-end.h \
        babeltrace2/graph/message-stream-beginning-const.h \
        babeltrace2/graph/message-stream-beginning.h \
+       babeltrace2/graph/message-stream-const.h \
        babeltrace2/graph/message-stream-end-const.h \
        babeltrace2/graph/message-stream-end.h \
        babeltrace2/graph/port-const.h \
This page took 0.023971 seconds and 4 git commands to generate.