Re-enable the bin-info and dward tests
[babeltrace.git] / include / Makefile.am
index 5bad3b7581caa14447e7d1a17593371f07d70a63..f929321067964b541afa5f164b470c5cae86f973 100644 (file)
@@ -1,12 +1,20 @@
+# Core API
+babeltraceincludedir = "$(includedir)/babeltrace"
 babeltraceinclude_HEADERS = \
        babeltrace/babeltrace.h \
        babeltrace/values.h \
        babeltrace/ref.h \
-       babeltrace/logging.h
+       babeltrace/logging.h \
+       babeltrace/version.h \
+       babeltrace/types.h
 
+# Legacy API (for CTF writer)
+babeltracectfincludedir = "$(includedir)/babeltrace/ctf"
 babeltracectfinclude_HEADERS = \
        babeltrace/ctf/events.h
 
+# CTF writer API
+babeltracectfwriterincludedir = "$(includedir)/babeltrace/ctf-writer"
 babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/clock.h \
        babeltrace/ctf-writer/writer.h \
@@ -16,6 +24,8 @@ babeltracectfwriterinclude_HEADERS = \
        babeltrace/ctf-writer/stream.h \
        babeltrace/ctf-writer/stream-class.h
 
+# CTF IR API
+babeltracectfirincludedir = "$(includedir)/babeltrace/ctf-ir"
 babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/clock-class.h \
        babeltrace/ctf-ir/fields.h \
@@ -30,10 +40,14 @@ babeltracectfirinclude_HEADERS = \
        babeltrace/ctf-ir/utils.h \
        babeltrace/ctf-ir/visitor.h
 
+# Plugin and plugin development API
+babeltracepluginincludedir = "$(includedir)/babeltrace/plugin"
 babeltraceplugininclude_HEADERS = \
        babeltrace/plugin/plugin.h \
        babeltrace/plugin/plugin-dev.h
 
+# Graph, component, and notification API
+babeltracegraphincludedir = "$(includedir)/babeltrace/graph"
 babeltracegraphinclude_HEADERS = \
        babeltrace/graph/clock-class-priority-map.h \
        babeltrace/graph/component-class-filter.h \
@@ -47,6 +61,8 @@ babeltracegraphinclude_HEADERS = \
        babeltrace/graph/component.h \
        babeltrace/graph/connection.h \
        babeltrace/graph/graph.h \
+       babeltrace/graph/notification-discarded-events.h \
+       babeltrace/graph/notification-discarded-packets.h \
        babeltrace/graph/notification-event.h \
        babeltrace/graph/notification-heap.h \
        babeltrace/graph/notification-inactivity.h \
@@ -68,17 +84,19 @@ noinst_HEADERS = \
        babeltrace/babeltrace-internal.h \
        babeltrace/bitfield-internal.h \
        babeltrace/common-internal.h \
-       babeltrace/compat/dirent-internal.h \
        babeltrace/compat/fcntl-internal.h \
        babeltrace/compat/glib-internal.h \
        babeltrace/compat/limits-internal.h \
        babeltrace/compat/memstream-internal.h \
        babeltrace/compat/mman-internal.h \
-       babeltrace/compat/send-internal.h \
+       babeltrace/compat/socket-internal.h \
        babeltrace/compat/stdio-internal.h \
        babeltrace/compat/stdlib-internal.h \
        babeltrace/compat/string-internal.h \
+       babeltrace/compat/time-internal.h \
+       babeltrace/compat/unistd-internal.h \
        babeltrace/compat/utc-internal.h \
+       babeltrace/compat/utsname-internal.h \
        babeltrace/compat/uuid-internal.h \
        babeltrace/compiler-internal.h \
        babeltrace/ctf-ir/attributes-internal.h \
@@ -108,6 +126,7 @@ noinst_HEADERS = \
        babeltrace/graph/component-source-internal.h \
        babeltrace/graph/connection-internal.h \
        babeltrace/graph/graph-internal.h \
+       babeltrace/graph/notification-discarded-elements-internal.h \
        babeltrace/graph/notification-event-internal.h \
        babeltrace/graph/notification-heap-internal.h \
        babeltrace/graph/notification-inactivity-internal.h \
@@ -117,10 +136,12 @@ noinst_HEADERS = \
        babeltrace/graph/notification-stream-internal.h \
        babeltrace/graph/port-internal.h \
        babeltrace/lib-logging-internal.h \
+       babeltrace/list-internal.h \
        babeltrace/logging-internal.h \
        babeltrace/mmap-align-internal.h \
        babeltrace/object-internal.h \
        babeltrace/plugin/plugin-internal.h \
        babeltrace/plugin/plugin-so-internal.h \
        babeltrace/prio-heap-internal.h \
-       babeltrace/ref-internal.h
+       babeltrace/ref-internal.h \
+       babeltrace/values-internal.h
This page took 0.024304 seconds and 4 git commands to generate.