Add logging API (internal to log, public to set the current log level)
[babeltrace.git] / lib / Makefile.am
index 26929ff32243d519824c08559559221c327f57f9..416d703c26438244e50b1ba5ce0a5e7db3fdc41c 100644 (file)
@@ -1,29 +1,19 @@
-SUBDIRS = ctf-ir ctf-writer prio_heap plugin component .
+SUBDIRS = ctf-ir ctf-writer prio_heap plugin graph .
 
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 
 lib_LTLIBRARIES = libbabeltrace.la
 
-libbabeltrace_la_SOURCES = babeltrace.c values.c ref.c
+libbabeltrace_la_SOURCES = babeltrace.c values.c ref.c logging.c
 libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
 
-if ENABLE_DEBUG_INFO
-noinst_LTLIBRARIES = libdebug-info.la
-
-libdebug_info_la_SOURCES = bin-info.c \
-                         dwarf.c \
-                         crc32.c \
-                         utils.c
-libdebug_info_la_LDFLAGS = -lelf -ldw
-libdebug_info_la_LIBADD = libbabeltrace.la
-endif
-
 libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/compat/libcompat.la \
-       component/libcomponent.la \
+       graph/libgraph.la \
        plugin/libplugin.la \
        $(top_builddir)/common/libbabeltrace-common.la \
+       $(top_builddir)/logging/libbabeltrace-logging.la \
        ctf-ir/libctf-ir.la \
        ctf-writer/libctf-writer.la
 
This page took 0.02278 seconds and 4 git commands to generate.