Initial implementation of the debuginfo API
[babeltrace.git] / lib / Makefile.am
index 348b0a9b2611977040911a3f8c13c195f0370026..42a94346ba8c6e43924baaf2647b50f616888358 100644 (file)
@@ -13,6 +13,16 @@ libbabeltrace_la_SOURCES = babeltrace.c \
 
 libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
 
+if ENABLE_DEBUGINFO
+noinst_LTLIBRARIES = libdebuginfo.la
+
+libdebuginfo_la_SOURCES = debuginfo.c \
+                           so-info.c \
+                           dwarf.c \
+                           crc32.c
+libdebuginfo_la_LDFLAGS = -lelf -ldw
+endif
+
 libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
This page took 0.022999 seconds and 4 git commands to generate.