Initial implementation of the debuginfo API
[babeltrace.git] / lib / Makefile.am
index 7ffb164657d42004bff9da3a49591e622fecb6f2..42a94346ba8c6e43924baaf2647b50f616888358 100644 (file)
@@ -11,7 +11,19 @@ libbabeltrace_la_SOURCES = babeltrace.c \
                           trace-collection.c \
                           registry.c
 
-libbabeltrace_la_LDFLAGS = \
-       -Wl,--no-as-needed \
+libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
+
+if ENABLE_DEBUGINFO
+noinst_LTLIBRARIES = libdebuginfo.la
+
+libdebuginfo_la_SOURCES = debuginfo.c \
+                           so-info.c \
+                           dwarf.c \
+                           crc32.c
+libdebuginfo_la_LDFLAGS = -lelf -ldw
+endif
+
+libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
-       $(top_builddir)/types/libbabeltrace_types.la
+       $(top_builddir)/types/libbabeltrace_types.la \
+       $(top_builddir)/compat/libcompat.la
This page took 0.022989 seconds and 4 git commands to generate.