Fix: --clock-force-correlate to handle trace collections gathered from various nodes
[babeltrace.git] / lib / Makefile.am
index 0c421cdb36d322c3bf14eb131513330d060397ea..7ffb164657d42004bff9da3a49591e622fecb6f2 100644 (file)
@@ -5,15 +5,13 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 lib_LTLIBRARIES = libbabeltrace.la
 
 libbabeltrace_la_SOURCES = babeltrace.c \
-                          callbacks.c \
                           iterator.c \
                           context.c \
                           trace-handle.c \
                           trace-collection.c \
-                          ctf-events.c
+                          registry.c
 
-libbabeltrace_la_LIBADD = \
-       $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la \
-       prio_heap/libprio_heap.la
+libbabeltrace_la_LDFLAGS = \
+       -Wl,--no-as-needed \
+       prio_heap/libprio_heap.la \
+       $(top_builddir)/types/libbabeltrace_types.la
This page took 0.022715 seconds and 4 git commands to generate.