Fix: handle packet_seek errors
[babeltrace.git] / lib / Makefile.am
index 26f024b447b4e50925389ccd99079cea4d4bd01e..c0749b7dfccde657acc3e91f59abc0b900451ca9 100644 (file)
@@ -5,11 +5,28 @@ AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 lib_LTLIBRARIES = libbabeltrace.la
 
 libbabeltrace_la_SOURCES = babeltrace.c \
-                          callbacks.c \
                           iterator.c \
                           context.c \
-                          trace-handle.c
+                          trace-handle.c \
+                          trace-collection.c \
+                          registry.c \
+                          error.c
+
+libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
+
+if ENABLE_DEBUG_INFO
+noinst_LTLIBRARIES = libdebug-info.la
+
+libdebug_info_la_SOURCES = debug-info.c \
+                         bin-info.c \
+                         dwarf.c \
+                         crc32.c \
+                         utils.c
+libdebug_info_la_LDFLAGS = -lelf -ldw
+libdebug_info_la_LIBADD = libbabeltrace.la
+endif
 
 libbabeltrace_la_LIBADD = \
+       prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
-       prio_heap/libprio_heap.la
+       $(top_builddir)/compat/libcompat.la
This page took 0.024065 seconds and 4 git commands to generate.