Add bt_plugin_create_from_name()
[babeltrace.git] / lib / Makefile.am
index 4b78b4778f6be7f709e48b824fcefa4a7b64581c..c47d581b8c819c3960bf1a5de0804b9eb545ea8d 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = prio_heap .
+SUBDIRS = prio_heap plugin component .
 
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 
@@ -9,9 +9,28 @@ libbabeltrace_la_SOURCES = babeltrace.c \
                           context.c \
                           trace-handle.c \
                           trace-collection.c \
-                          registry.c
+                          registry.c \
+                          values.c \
+                          ref.c
+
+libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
+
+if ENABLE_DEBUG_INFO
+noinst_LTLIBRARIES = libdebug-info.la
+
+libdebug_info_la_SOURCES = debug-info.c \
+                         bin-info.c \
+                         dwarf.c \
+                         crc32.c \
+                         utils.c
+libdebug_info_la_LDFLAGS = -lelf -ldw
+libdebug_info_la_LIBADD = libbabeltrace.la
+endif
 
 libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/compat/libcompat.la
+       $(top_builddir)/compat/libcompat.la \
+       component/libcomponent.la \
+       plugin/libplugin.la \
+       $(top_builddir)/common/libbabeltrace-common.la
This page took 0.024506 seconds and 4 git commands to generate.