Add bt_plugin_create_from_name()
[babeltrace.git] / lib / Makefile.am
index edae4bee359b264272f724eebb915a5ab1a6b8b0..c47d581b8c819c3960bf1a5de0804b9eb545ea8d 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = prio_heap .
+SUBDIRS = prio_heap plugin component .
 
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
 
@@ -15,17 +15,22 @@ libbabeltrace_la_SOURCES = babeltrace.c \
 
 libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
 
-if ENABLE_DEBUGINFO
-noinst_LTLIBRARIES = libdebuginfo.la
+if ENABLE_DEBUG_INFO
+noinst_LTLIBRARIES = libdebug-info.la
 
-libdebuginfo_la_SOURCES = debuginfo.c \
-                           so-info.c \
-                           dwarf.c \
-                           crc32.c
-libdebuginfo_la_LDFLAGS = -lelf -ldw
+libdebug_info_la_SOURCES = debug-info.c \
+                         bin-info.c \
+                         dwarf.c \
+                         crc32.c \
+                         utils.c
+libdebug_info_la_LDFLAGS = -lelf -ldw
+libdebug_info_la_LIBADD = libbabeltrace.la
 endif
 
 libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
-       $(top_builddir)/compat/libcompat.la
+       $(top_builddir)/compat/libcompat.la \
+       component/libcomponent.la \
+       plugin/libplugin.la \
+       $(top_builddir)/common/libbabeltrace-common.la
This page took 0.023954 seconds and 4 git commands to generate.