Initial implementation of the debuginfo API
[babeltrace.git] / lib / Makefile.am
index ef1bcf9be752d25043fe0c3d5ac74c7466e7f459..edae4bee359b264272f724eebb915a5ab1a6b8b0 100644 (file)
@@ -15,6 +15,16 @@ libbabeltrace_la_SOURCES = babeltrace.c \
 
 libbabeltrace_la_LDFLAGS = -version-info $(BABELTRACE_LIBRARY_VERSION)
 
+if ENABLE_DEBUGINFO
+noinst_LTLIBRARIES = libdebuginfo.la
+
+libdebuginfo_la_SOURCES = debuginfo.c \
+                           so-info.c \
+                           dwarf.c \
+                           crc32.c
+libdebuginfo_la_LDFLAGS = -lelf -ldw
+endif
+
 libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
This page took 0.023273 seconds and 4 git commands to generate.