lib: add internal object pool API and use it; adapt plugins/tests
[babeltrace.git] / lib / ctf-ir / Makefile.am
index ca59585b0389ec632b04121406116ad3ba3fce56..56075a80e8ecfc56168c96b9b18a6a0cbf7fa536 100644 (file)
@@ -5,10 +5,14 @@ libctf_ir_la_SOURCES = \
        clock-class.c \
        event.c \
        event-class.c \
+       event-header-field.c \
+       field-wrapper.c \
        fields.c \
        field-types.c \
        field-path.c \
        packet.c \
+       packet-context-field.c \
+       packet-header-field.c \
        stream.c \
        stream-class.c \
        trace.c \
@@ -17,12 +21,4 @@ libctf_ir_la_SOURCES = \
        validation.c \
        visitor.c
 
-libctf_ir_la_LIBADD =
-
-if BABELTRACE_BUILD_WITH_LIBUUID
-libctf_ir_la_LIBADD += -luuid
-endif
-
-if BABELTRACE_BUILD_WITH_LIBC_UUID
-libctf_ir_la_LIBADD += -lc
-endif
+libctf_ir_la_LIBADD = $(UUID_LIBS)
This page took 0.024612 seconds and 4 git commands to generate.