Create a library to copy a CTF trace
[babeltrace.git] / plugins / Makefile.am
index 28bd175d3021df7dc9bfdfb7020da80e1a7df814..75c3b1e6632d58beb0d7593e8fb3fc2c16e2a41b 100644 (file)
@@ -1,22 +1,3 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = ctf text muxer utils libctfcopytrace writer
 
-SUBDIRS = . ctf text
-
-lib_LTLIBRARIES = libbabeltrace-plugin.la
-
-# Plug-in system library
-libbabeltrace_plugin_la_SOURCES = \
-       component.c \
-       component-class.c \
-       component-factory.c \
-       plugin.c \
-       source.c \
-       sink.c \
-       iterator.c
-
-# Request that the linker keeps all static library objects.
-libbabeltrace_plugin_la_LDFLAGS = \
-       -Wl,--no-as-needed -version-info $(BABELTRACE_LIBRARY_VERSION)
-
-libbabeltrace_plugin_la_LIBADD = \
-       $(top_builddir)/lib/libbabeltrace.la
+noinst_HEADERS = plugins-common.h
This page took 0.023163 seconds and 4 git commands to generate.