lib: add internal object pool API and use it; adapt plugins/tests
[babeltrace.git] / plugins / text / Makefile.am
index ef376f7b83abd74e3c70d2db7497f726d2e0087d..f7bfff8e900da02b176db1fe85d4207e97f2bf36 100644 (file)
@@ -1,6 +1,6 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/plugins
+AM_CPPFLAGS += -I$(top_srcdir)/plugins
 
-SUBDIRS = pretty .
+SUBDIRS = pretty dmesg
 
 plugindir = "$(PLUGINSDIR)"
 plugin_LTLIBRARIES = babeltrace-plugin-text.la
@@ -11,11 +11,13 @@ babeltrace_plugin_text_la_LDFLAGS = \
        -avoid-version -module
 
 babeltrace_plugin_text_la_LIBADD = \
-       pretty/libbabeltrace-plugin-text-pretty-cc.la
+       pretty/libbabeltrace-plugin-text-pretty-cc.la \
+       dmesg/libbabeltrace-plugin-text-dmesg-cc.la
 
-if !BUILT_IN_PLUGINS
+if !ENABLE_BUILT_IN_PLUGINS
 babeltrace_plugin_text_la_LIBADD += \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/common/libbabeltrace-common.la \
-       $(top_builddir)/logging/libbabeltrace-logging.la
+       $(top_builddir)/logging/libbabeltrace-logging.la \
+       $(top_builddir)/compat/libcompat.la
 endif
This page took 0.024618 seconds and 4 git commands to generate.