Cleanup: Move build logic to python-plugin-provider Makefile
[babeltrace.git] / python-plugin-provider / Makefile.am
index 294629e34d39371a76d79f16b79b5101d913e395..2a269f0ff0e2a84c81539b86c84cd79f7147b60d 100644 (file)
@@ -1,3 +1,4 @@
+if ENABLE_PYTHON_PLUGINS
 AM_CPPFLAGS += $(PYTHON_INCLUDE)
 
 lib_LTLIBRARIES = libbabeltrace2-python-plugin-provider.la
@@ -11,9 +12,12 @@ libbabeltrace2_python_plugin_provider_la_LDFLAGS = \
 
 libbabeltrace2_python_plugin_provider_la_LIBADD =
 
+# Link the Python plugin provider library with libbabeltrace2
+# when it's not built-in the babeltrace2 executable.
 if !ENABLE_BUILT_IN_PLUGINS
 libbabeltrace2_python_plugin_provider_la_LIBADD += \
        $(top_builddir)/logging/libbabeltrace2-logging.la \
        $(top_builddir)/common/libbabeltrace2-common.la \
        $(top_builddir)/lib/libbabeltrace2.la
 endif
+endif # ENABLE_PYTHON_PLUGINS
This page took 0.025191 seconds and 4 git commands to generate.